Re: Instein box running OnStep 4.17k


"Guilherme Vênere
 

Hello again

I was able to fix the issue with flashing the Wifi module. The Instein custom OnStep uses a bridge between SerialA and SerialB on initialization to send the firmware to the wifi module directly without using the :ESPFLASH# command. 

But now i'm facing an issue which i can't solve and i need some help. If I flash OnStep 4.17, the Wifi module won't work at all. It doesn't matter if i use the one from Instein code (based on 3.16 release) or the Wifi module from the master branch. However if I flash OnStep 3.16, both the old and the new Wifi module work fine. As a test, i tried to connect to the web server using TELNET on port 80, and i got the error below when i sent a simple HTTP GET request

image.png

Which indicates the server is running, but something in the backend is not. I suspect that the Wifi module is not able to communicate properly with OnStep, but i can't find where this code is. I'm looking at OnStep code, since this is the variable that breaks the server when I change.

Everything else seems to be working fine. I can connect my SHC and it reports the correct firmware version in OnStep, and I can connect to the box via USB, and even slew with Stellarium. It's only the Wifi module which is not working, neither the web server nor the control ports (9999 and 9998)
 
Khalid or Howard, any idea where i can look next?

Thanks

Guilherme



On Sat, Oct 17, 2020 at 6:43 PM "Guilherme Vênere via groups.io <venere=gmail.com@groups.io> wrote:
Hello

  This is mainly for owners of the Instein box. I think I have succeeded in updating mine to the latest master OnStep 4.17k. It required a few changes to add the Ïnstein pinmap and update some variable names to the 4.xx nomenclature, but i was able to successfully upload the sketch and connect with my SHC (see image)  

image.png

I still need to check if the motors are moving correctly, but the issue I found so far is that i'm unable to flash the Wifi module with the latest code. I'm not sure if the changes to OnStep would affect the wifi reflashing, as the box has a switch to flash wifi separately from the main module. I might be doing something stupid there but still need to confirm. When booting normally, the web server respond but i'm getting empty pages every time

If i can fix this issue and confirm everything works with the hardware, i will send a pull request with the changes to Github and Howard can decide what to do, but i'll keep a copy on my Github too.

There's one thing though i don't know how to solve, and i may need help from someone more experienced in programming here. Instein require changes to two pins in HardwareSerial.cpp as mentioned in his custom code:

// - ADITIONALLY YOU MUST MADE A CHANGE on your HardwareSerial.ccp file code lines 10 & 14, this file is usually located on:
//     C:\Users\xxxx\AppData\Local\Arduino15\packages\esp32\hardware\esp32\1.0.1\cores\esp32\HardwareSerial.ccp
//     Change the lines "#define RX1 9" & "#define TX1 10" by "#define RX1 21" & "#define TX1 22" respectively.
//     This change is mandatory for this firmware to work and in this way, OnStep AUX port will work as second serial port an enable
//     a set of conectivity options: aditional wifi, bluetooth or USB, RF Link, ethernet or future serial devices.   

Is there a way to overwrite these changes from OnStep code itself to avoid having to mess around with the library files? 

Guilherme



Join main@onstep.groups.io to automatically receive all group messages.