Date   

Re: #wifi #wifi

Mesquita
 

sorry if i didn't understand, but the espduino i bought already comes with the integrated esp8266 wifi and bluetooth

Em qui, 19 de mai de 2022 19:24, Chad Gray <rchadgray@...> escreveu:

You need to use a seperate ESP8266 for WiFi.

The ESP8266 connects to the CNC on these pins for RX TX.

Also the 5V on the CNC is not 5V.  Check with voltmeter and supply separate 5V to ESP8266

image.png

On Thu, May 19, 2022 at 5:47 PM Mesquita <Costaroberto56@...> wrote:
Bos night, group.
I mounted onstepx on a cnc 3, and a spduino board with Bluetooth and wifi onboard, bluetooth works normally, but wifi doesn't work,I checked the on option to upload the esp8266, but I can't get a wifi signal. Can anyone help me with this problem?


Re: #wifi #wifi

Chad Gray
 

You need to use a seperate ESP8266 for WiFi.

The ESP8266 connects to the CNC on these pins for RX TX.

Also the 5V on the CNC is not 5V.  Check with voltmeter and supply separate 5V to ESP8266

image.png


On Thu, May 19, 2022 at 5:47 PM Mesquita <Costaroberto56@...> wrote:
Bos night, group.
I mounted onstepx on a cnc 3, and a spduino board with Bluetooth and wifi onboard, bluetooth works normally, but wifi doesn't work,I checked the on option to upload the esp8266, but I can't get a wifi signal. Can anyone help me with this problem?


#wifi #wifi

Mesquita
 

Bos noite, grupo.
Montei o onstepx em um cnc 3, e uma placa spduino com bluetooth e wifi onboard, bluetooth funciona normalmente, mas wifi não funciona, marquei a opção on para fazer upload do esp8266, mas não consigo sinal wifi. Alguém pode me ajudar com esse problema?


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

Just as a reality check I downloaded the Config.h file linked to in the Wiki and uploaded OnStep 4.24q to my MaxSTM3.6 here.  It has BTT TMC2130 V3.0 SPI drivers.

An earlier revision, but basically the same thing.

It works fine.

I did notice that the ESP flashing provision is active in that Config.h file where it shouldn't be.  I fixed that but don't see why it would cause trouble.


#wifi #wifi

Mesquita
 

Bos night, group.
I mounted onstepx on a cnc 3, and a spduino board with Bluetooth and wifi onboard, bluetooth works normally, but wifi doesn't work,I checked the on option to upload the esp8266, but I can't get a wifi signal. Can anyone help me with this problem?


Re: FYSETC E4

Howard Dutton
 

I can confirm that nothing strange seems to be going on with my MaxESP3 with the latest changes to OnStepX (and its TMC2209U drivers in TX only hardware serial mode.)


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 01:39 PM, Howard Dutton wrote:
BTT TMC2130 V3.0 SPI driver without the set of pins off to the side
Talking about the two pins standing up next to the Vref trim-pot.


Re: MaxSTM3.6 motors not moving

Howard Dutton
 


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 12:43 PM, glyderman wrote:
Ok donation taken care of under my wife's paypal name Christine.
Thank you, rather you got it working first though!


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 12:24 PM, glyderman wrote:
Are they a direct dropin on a MKS-Gen L V1 board?
No, v2.0 and v2.1 they are drop in.  Can be used but more complicated.


Re: opinion on rebuild mini pcb 2 #mini

alex.military95@...
 

Thanks for the reply. my problem is to have a board as compact as possible I will eliminate the 4.1 tension and I will put the 4.0 ok this allows me to further reduce the space. as far as the capacitors are concerned, I plan to order the preassembled board directly from the manufacturer in this way so as not to redo there are short-circuit problems. The other problem I didn't understand what you mean as I use google translate and I don't understand what the problem is. the fact is that i need a very small pcb for my mini mount which i designed. then not so if it is possible to order the bord already pre-assembled by them with the original design.


Re: MaxSTM3.6 motors not moving

glyderman
 

 Ok donation taken care of under my wife's paypal name Christine. Mine is iain. I should of given you something last year, sorry about that. Do not beleive in using other peopls work wwthout saying thanks.


Re: MaxSTM3.6 motors not moving

glyderman
 

Hmm  chating to you has reminded me that I have not donated anything to you for 2 years.Time to change that now. You deserve to be rewarded and I have enjoyed the product of your brains for last 2 years. Maybe I should show the group  some of my pohotos and the build i did.


Re: MaxSTM3.6 motors not moving

glyderman
 

I will have to change config.h and Vref obviously but not sureif oldbaord works with SPI. I willhave to research that.


Re: MaxSTM3.6 motors not moving

glyderman
 

Thanks for reply Howard

These were sold as SPI and presoldered pins. Bought from a private seller as unused in their boxes from ebay. Hope they are actually ok. Are they a direct dropin on a MKS-Gen L V1 board? If so I could plug them into my old controller which works with DRV8825 drivers  and seeif these 2130 drivers are faulty.

Also a great thank you for all the hardwork you have put into Onstep over the years.

I am baffled at the moment about this problem.


Re: 4.24q will not run

glyderman
 

I am using 4.24q on a MAXSMT3.6 board. When I flashed the blackpill it worked ok 1st time. When I tried to flash again because of problems with my motors the port on arduino was greyed out and it failed to upload.. It took me several retries before it flashed again. It flashed even though the port selction was greyed and was previously set to the port used when just powering up the controller without pressing bootload and reset. No idea why it flashed the second time finally as I had tried about 7 times unsuceesfully.


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 11:56 AM, Howard Dutton wrote:
On Thu, May 19, 2022 at 11:45 AM, glyderman wrote:
The drivers are both Bigtree TMC2130 v3.
Two kinds of those: one "SPI" works properly the other "DIY" doesn't.
Typical symptoms are not what you are seeing however.


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 11:45 AM, glyderman wrote:
The drivers are both Bigtree TMC2130 v3.
Two kinds of those: one "SPI" works properly the other "DIY" doesn't.


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 11:45 AM, glyderman wrote:
I have not populated ST4, RJ3,  RJ4, and J2 positions on the board as I will not be using them yet and the parts are very difficult to get at the moment. I can't see that this would affect anything but perhaps I am wrong.
None of this matters.


Re: MaxSTM3.6 motors not moving

Howard Dutton
 

On Thu, May 19, 2022 at 11:45 AM, glyderman wrote:
I have soldered in the pull down resistors, R19 and R20, that would be used on pin for DCO/CLK on TMC5160 drivers. I did this as I may use these drivers later.
Was this correct or should I have left them out with these TMC2130 drivers?
Only needed for some TMC5160 drivers; present or not doesn't matter for TMC2130 drivers in all cases I know of.

As mentioned before, I used in C1, C2, C3 100uF 100v not 100uF 50v. All other components are as recommende
Using a higher voltage rated cap makes no difference.

1 - 20 of 43715