Topics

FYSETC S6 Virtual serial disappears #fysetc


Hemant Kulkarni
 

I am experimenting on fysetc s6 v1.2 board, I have followed instruction on the wiki to boot the board  into bootloader mode and flash Onstep 4.23d  using modified DFU script. After upload when I press reset button or unplug/plug the USB,  I can see the virtual serial port in device manager. I can send commands using the Arduino serial monitor to it and get valid replies. However when i turn the 24V power to the board, this COM port disappears and I cannot use the USB type B interface. I can see that Onstep is working as I can connect with wifi or SkySafari and move the mount etc. If I disconnect the power, the serial port reappears. Can I not use this serial port on this board as explained in Connecting wiki?


-Hemant


Hemant Kulkarni
 

So  there were few issues I saw not only did the COM port driver vanish, but an unknown device appeared in USB hub section of device manager. I had installed STM's virtual COM port driver. It is very poorly written and does not enumerate the device well on Win 10. I removed it, then I saw the port simply disappeared. I removed all the components connected to the board, it worked. Then I added Wemos D1 and GPS it continued to work each time. It failed again when I inserted the S109 drivers. I noticed the RA driver seemed to not cause trouble. I had an old DRV8825 lying around, replaced DEC S109 with it and flashed Onstep with this config. It worked. Then I noticed the VIO pin on Fysetc S6 is VDD pin on S109 which acts as logic high. I chopped it off and so far it has seemed to work every time.

-Hemant