Onstep disconnects when i try to slew #wemos #fysetc #EQ3 #S6


Juan Sebastian
 

Hi guys!

well, my onstep build moves when i test it without the mount, but when i connect it to the real thing im having issues, im able to connecto tho the wemos/app, set date and time, and un-park the mount (without telescope), but as soon as i try to move the motors they move just a little bit and the wemos disconnects, 
Im thinking this is related somehow to V or am

¿Can someone check the upcoming info and tell me please what should i do:

  • EXOS-NANO (EQ3) mount
  • FYSETC S6 V2.0 Board -> LINK
  • x2 TMC2130 v1.1 (vref set to 0.8v in both mottors) -> LINK
  • x2 STEPPERONLINE 0.9deg Nema 17 Stepper Motor Bipolar 0.9A 36Ncm/50oz.in 42x42x39mm 4-wires -> LINK
  • 19v 3.42A power supply
  • Config.h attached (DRIVER_IRUN set to 600, DRIVER_IGOTO set to 888)


Khalid Baheyeldin
 

I have an S6 v2.0 board, with TMC5160 configured for IRUN 675 and IGOTO 850 for slewing, and a 19V 4.74A power supply.
Because of the winter season, the last time I used the power supply was in November.
When I tried the same hardware in March, I noticed that on powerup, the 3 LEDs on the S6 would blink intermittently before the board, and the Wemos would power up. Then on the first slew, the motors would move a few degrees, then the board would lose power completely.

A friend inspected the power supply (from an HP laptop) and found that it is defective.
I used another power supply, and the mount work. No blinking LEDs, no power loss, normal slewing.

Not saying that this is definitely your problem, but a 19V power supply should run your setup.
Another data point: I also used a 12V 2A power supply with the same IRUN and IGOTO, and it works well. So the 3.4A should not be a problem, unless you are running a heater (maybe).


Juan Sebastian
 

You were right, i tried with other DC and i had no problems, once more thank you khalid!