Below Horizon Issue #ascom


astrosathya
 

I finally managed to get OnStep to connect to my Wemos D1 R2. It takes a few seconds to connect. Thats alright. However, I immediately noticed two things.
1) It shows LST (Local Standard Time) I assume? about 5.5 hours more than actual local time which was 16:20 as of the time the video was recorded. Changing the UTC settings did not make any change in that value. I am at +5hrs 30m UTC. 
Secondly and I believe as a result of the above issue, any object I select is popping up the error "Below Horizon" as can be seen in the video
I'd be very grateful for help.
Thanks,
Sathya.


Martin Chapman
 

Hi Astrosathya, Not sure if it's the same issue, I posted a similar problem last night, where my time was, strangely, 5 hours different, the answer from Khalid was to check the 3 buttons, top right of the opening screen, and select use current location. I was a little embarrassed that this worked, because it is what I was doing before, and somehow I forgot.
Hope this helps.

On Mon, May 17, 2021 at 12:00 PM astrosathya <skpsharma@...> wrote:
I finally managed to get OnStep to connect to my Wemos D1 R2. It takes a few seconds to connect. Thats alright. However, I immediately noticed two things.
1) It shows LST (Local Standard Time) I assume? about 5.5 hours more than actual local time which was 16:20 as of the time the video was recorded. Changing the UTC settings did not make any change in that value. I am at +5hrs 30m UTC. 
Secondly and I believe as a result of the above issue, any object I select is popping up the error "Below Horizon" as can be seen in the video
I'd be very grateful for help.
Thanks,
Sathya.


astrosathya
 

Hi Martin,
The bigger issue is also that OnStep does not connect to the board. Its a hit/miss. Also I am unable to understand which 3 buttons you are referring to please.
I need to therefore solve this connection issue (video here) too before I try to access anything else.
 


Martin Chapman
 

Ah, sorry, my mistake, I assumed you were using the onstep app, on a phone or tablet, I have not tried with CdC, only with Stellarium and SkyPlanetarium, so far.
Sorry.
Mart.

On Mon, May 17, 2021 at 12:22 PM astrosathya <skpsharma@...> wrote:
Hi Martin,
The bigger issue is also that OnStep does not connect to the board. Its a hit/miss. Also I am unable to understand which 3 buttons you are referring to please.
I need to therefore solve this connection issue (video here) too before I try to access anything else.
 


astrosathya
 

I re-flashed the firmware and connected again. The problem persists.


Drew 🔭📷🚴‍♂️
 

On Mon, May 17, 2021 at 06:59 AM, astrosathya wrote:
1) It shows LST (Local Standard Time) I assume?
No, it is Local Sidereal Time. What I did was get an Astronomical time utility. There are several available for Windows, Android and On the web. This will allow you to compare your time with what you are seeing.

Your time zone is -5.5 hours. Note that it is opposite, hence negative. This is a hangover from the old LX200 method if I am not mistaken.


Alan Pounder
 

LST is not local standard time, it is local sidereal time. Also check your site coordinates. You may have the sign wrong on your longitude.

Regards, AlanP


On 17 May 2021, at 14:57, astrosathya <skpsharma@...> wrote:

I re-flashed the firmware and connected again. The problem persists.
<Time Issue.JPG>


adraasch
 

Sathya,

LST = Local Sidereal Time.  This is not Local Standard Time.  It is the Right Ascension (RA) that is directly above an observer on Earth.  (Another way of saying the RA of the observer's meridian).

For a discussion on what that means, this site may help:

If you have Sky Safari, you can see the current LST by opening the settings page and selecting Date and Time.  Local Sidereal Time is then displayed.

With OnStep, a very good check on initial startup is to verify that the mount's LST agrees closely with the observer's LST, as the OnStep controlled mount uses this value to determine where to point. 

If OnStep has the wrong LST value, OnStep will either point your scope in a position that is not where you want it, or refuse to move the scope as it determines that that object would be located below the horizon or near the observer's zenith (an area of the sky that can lead to telescopes striking the mount on equatorial mounts).

Hope this helps,

Arlen

On Mon, May 17, 2021 at 7:00 AM astrosathya <skpsharma@...> wrote:
I finally managed to get OnStep to connect to my Wemos D1 R2. It takes a few seconds to connect. Thats alright. However, I immediately noticed two things.
1) It shows LST (Local Standard Time) I assume? about 5.5 hours more than actual local time which was 16:20 as of the time the video was recorded. Changing the UTC settings did not make any change in that value. I am at +5hrs 30m UTC. 
Secondly and I believe as a result of the above issue, any object I select is popping up the error "Below Horizon" as can be seen in the video
I'd be very grateful for help.
Thanks,
Sathya.


Dave Schwartz
 

Try setting your UTC offset. It would be -5:30 in your case (opposite of the sign of your time zone). With an incorrect idea of the time, the lists will not be filtered properly for what is in your sky.

P.S. LST stands for local SIDEREAL time (i.e. the RA on your meridian at the moment)

On 2021-05-17 9:57 a.m., astrosathya wrote:
I re-flashed the firmware and connected again. The problem persists.


astrosathya
 

I changed the UTC offset to -5:30 and the Longitude to -77deg etc etc. This is weird because in reality I am +77deg as I am East of GMT. Anyway, the goto test was a success, though the slew rate is slow at 2.49deg/sec. I will recalculate and re-flash the firmware to reflect a faster slew rate.
Now the only remaining issue is that the connection getting established successfully is a hit/miss. I had to press the reset button this time for it to connect. 
Is there any way to avoid doing that each time?
The video here shows my latest test.


Dave Schwartz
 

+77 degree longitude should be correct for you. I am in Ontario, Canada and my longitide is -80 but this is shown as +80 in the ASCOM dialog. This was set by GPS so the signs will be correct. So for you in India, the ASCOM longitude should have a - sign.

2.49 degrees/sec is pretty fast when you actually see a telescope moving at that rate. Much faster can actually be scary. I forgot what controller hardware you have but it may not be capable of anything faster.

On 2021-05-17 11:59 a.m., astrosathya wrote:
I changed the UTC offset to -5:30 and the Longitude to -77deg etc etc. This is weird because in reality I am +77deg as I am East of GMT. Anyway, the goto test was a success, though the slew rate is slow at 2.49deg/sec. I will recalculate and re-flash the firmware to reflect a faster slew rate.
Now the only remaining issue is that the connection getting established successfully is a hit/miss. I had to press the reset button this time for it to connect.
Is there any way to avoid doing that each time?
The *video here* <https://drive.google.com/file/d/1vlCKhqf6K16OsB9Agu-bDKpZHLke5szp/view?usp=sharing>shows my latest test.


astrosathya
 

Yes, its only after setting it to -77 that its working now. However the primary issue still remains. Establishing connection is not always guaranteed. 
My telescope would slew at 3.5deg/s. :) when it had the original motherboard. That mount was nearly 9 years old when the board died (almost a year after the Rowan Belt Mod).
I have the Wemos controller and looks like that's the fastest it can do.


Khalid Baheyeldin
 

On Mon, May 17, 2021 at 10:44 AM, Drew 🔭📷🚴‍♂️ wrote:
On Mon, May 17, 2021 at 06:59 AM, astrosathya wrote:
1) It shows LST (Local Standard Time) I assume?
No, it is Local Sidereal Time. What I did was get an Astronomical time utility. There are several available for Windows, Android and On the web. This will allow you to compare your time with what you are seeing.
Here is one site, which requires no input

https://www.localsiderealtime.com/

Here is another which requires input

https://sidereal.app/calculate

Either way, it will give you what your LST should be, so you can compare


Khalid Baheyeldin
 

On Mon, May 17, 2021 at 07:22 AM, astrosathya wrote:
The bigger issue is also that OnStep does not connect to the board. Its a hit/miss.
Is this for ASCOM or the phone App?

If it is the phone App, do you connect over Bluetooth or WiFi

If it is ASCOM, do you use WiFi or USB?


astrosathya
 

Its for ASCOM through USB. The OnStep console simply says "Not Responding" many times and i have to press the reset switch.


astrosathya
 

I tested once again today and the connection issue repeats. Apart from that issue, everything else seems to be fine as seen in the Video.

If i need a reset switch outside the plastic case, can i simply draw two wires from the E-Stop header and GND to a push button switch? Will it work as a reset?


Khalid Baheyeldin
 

On Tue, May 18, 2021 at 12:30 AM, astrosathya wrote:
If i need a reset switch outside the plastic case, can i simply draw two wires from the E-Stop header and GND to a push button switch? Will it work as a reset?
If the purpose of the reset switch is to get over the connection issue, then that is not a practical solution at all.
Any time you power off OnStep it loses track of where the telescope is pointing (unless you have encoders which only a bunch of people have), and all the alignment corrections.

Better to find the root cause.


astrosathya
 

You are one of the "Guru's" of OnStep. Please advice how to find the root cause.
:)


Khalid Baheyeldin
 

On Tue, May 18, 2021 at 10:18 AM, astrosathya wrote:
Please advice how to find the root cause.
I would love to, but I can't.
I neither have the board you are using, nor do I use Windows/ASCOM.


Howard Dutton
 

On Mon, May 17, 2021 at 04:22 AM, astrosathya wrote:
The bigger issue is also that OnStep does not connect to the board. Its a hit/miss. Also I am unable to understand which 3 buttons you are referring to please.
I need to therefore solve this connection issue (video here) too before I try to access anything else.
Not sure why this isn't working for you but you might want to try the following in the ASCOM setup dialog:

Once the connection attempt fails, select the empty/blank entry in the "Port" list box.
Then uncheck "[   ] Enable Serial Port DTR Control".
Then select "Com7" I guess it is back into the Port list box.

See if that helps it connect.