Blue pill on astroberry


Focdarthvaderxi@...
 

I am setting up the blue pill using the PCB board and the lv8729 drivers, and I am running astroberry on the RPi 4. I have flashed the blue pill and was trying to setup it up on kstars/ekos, it connects but the motors will not do anything. I am at a loss for what could be wrong can someone point me in the right direction. thanks


Khalid Baheyeldin
 

Did you set the location and time correctly?
From a terminal (e.g. picocom), try the commands at the end of this page.


Focdarthvaderxi@...
 

Yes on the time, I installed picocom and started the terminal but it will not let me type anything


Khalid Baheyeldin
 

I use this command:

picocom -b 9600 /dev/ttyUSB0

Then I type:

:GU#

What you type may not show, but you should get a response.

Let us know if you do.


Focdarthvaderxi@...
 

after I typed :GU# I got nNpHzAo250# not sure if the motors were supposed to do anything or if this even means anything


Khalid Baheyeldin
 

You got a response from :GU, which means that OnStep is working as it should.
What the specific characters mean is irrelevant in your case.

Now, try the commands in the link that I sent you earlier, and see if the motors move or not.

If they don't then it may be a connection or power supply problem.


Focdarthvaderxi@...
 

Sorry for the delayed response but I haven't had a chance to work on it again. I tried the other commands and no motor movement. 


Khalid Baheyeldin
 

Then your problem is either the wiring from the drivers to the motors, or the power supply.


James Lancaster
 

Make sure either you start alignment or turn on tracking. There's a message in the INDI control panel if it's not, as it won't move normally without that. (There are some options in OnStep that can be set to change that, but that's not normally the case.)


On Sun, Sep 12, 2021, 13:21 Khalid Baheyeldin <kbahey@...> wrote:
Then your problem is either the wiring from the drivers to the motors, or the power supply.


Khalid Baheyeldin
 

On Mon, Sep 13, 2021 at 08:40 AM, James Lancaster wrote:
Make sure either you start alignment or turn on tracking.
That is no longer necessary on 4.24, provided that the location and time have been entered.
OnStep detects that you have a valid location (which is not the default 0 latitude and 0 longitude),
and a valid time (the Blue Pill has an RTC that provides it), and responds like commercial mounts
when given a goto command.


Mike Ahner
 

On Sat, Sep 4, 2021 at 10:11 PM, <Focdarthvaderxi@...> wrote:
after I typed :GU# I got nNpHzAo250#
It appears that your baudrate is wrong, that's a garbage response. If so, then no other serial commands will work, so the motors will not move either.
I would check the baudrate settings and try others, starting at 9600,8,N,1, then 19,200, the 38,400


Khalid Baheyeldin
 

On Mon, Sep 13, 2021 at 09:20 PM, Mike Ahner wrote:
after I typed :GU# I got nNpHzAo250#
It appears that your baudrate is wrong, that's a garbage response.
No, it is a perfectly valid one.

n and N mean not slewing and not tracking
p means not parked

And so on ...

Details can be found in Command.ino.


Focdarthvaderxi@...
 

I am trying to work on this again, as for the power supply what do you recommend? And how would I go about checking the wiring?