Problem after switch from Teensy 3.2 to 4.0 #mini


Markus Emmerich
 

Hello,

I have a problem after I switched from the Teensy 3.2 to Teensy 4.0.

My Setup

  • Custom OnStep Board (3.3v level at every pin)
  • Teensy 4.0
  • pinmap: MiniPCB
  • Driver: TMC2100 (RA & DEC)
  • Comunication: ESP8266 or Bluetooth
  • Android-App
  • SHC


The Teensy 3.2 works perfect with this setup.
If I use the Teensy 4.0 I can open the connection, send date/Time and can start tracking and can slew the mount. But if I'm using the direction keys with a speed of 20x and higher the Teensy 4.0 seems to stop working for one minute or so:

  • Tracking stops
  • The Wifi & Bluetooth connection cuts off
  • If connected: Black screen at the SHC. No data from the OnStep-Board

That happens with the App, the browser-menue and the SHC. I switch the hardware between Bluetooth, ESP8266 and the SHC. Every time it's the same problem.

Upload settings

  • Arduino IDE v1.8.19
  • OnStep v4.24p
  • Teensyduino v1.56
  • CPU-Speed: tried vor 24 to 600 Mhz

 

I attached my Config.h.
Does anyone have an idea what's wrong?

Best regards
Markus

 


Chris Whitener
 

I just looked at the pins.  they are different.  did you go to MiniPCB2?  or just stick in the 4.0 chip?


Chris Whitener
 

Also dont you need to set the pinmap to MiniPCB2 for the 4.0


Markus Emmerich
 

Hello Chris,

I only stick in the Teensy 4.0. The used pinmap at my custom board is MiniPCB not MiniPCB2.
I compared the pins from Teensy 3.2 and 4.0 and can't find any difference betwenn the used pins. What difference did you mean?

Best regards

 

 


Chris Whitener
 

if you look at the comment line for Pinmap in config.h  you can see that there is a choice including "MiniPCB2"  so there must be a difference somewhere.


Markus Emmerich
 

Now I tried out config-h with MiniPCB and MiniPCB2. The Teensy4.0 was mounted at an breadboard. The only data connetion was RX and TX to the ESP8266 module. So it was impossible get a hardware issue at the pins.
It's the same problem like describt before. For me it's not a pinmap or Hardware issue. I also tried this setup with a second Teensy 4.0. It's always the same.

Best regards


George Cushing
 

Think that is to distinguish between PCB version 1.276 and version 2.0. V. 1.276 uses the ESP-1 version of the ESP8266. The MiniPCB2 uses the D1 mini.

There is no MiniPCB13 pinmap. The choices are MiniPCB or MiniPCB2. So my guess is that it's a variant for a board or accessory function not normally supported by the PCB.

I've given up on the D1 mini Pro. They are pushing $7 and fluky. I either solder the cable or a coaxial cable connector to a D1 mini. 


Markus Emmerich
 

Hi George,

I don't use the D1 mini Pro. Since serveral years I'm working with the ESP8266-07 remote serial board:



It only needs Vcc, GND, RX, TX. It works with 3.3 - 5v TTL.

I also tested the connection via the Bluetooth serial module HC-06. Its always the same issue as descript at my first post.

For me it looks like an interrupt at the serial connection when I push the direction keys with 20x and over. No matter if I'm using the Browser, the App or the SHC. That's why I'm sure it's no a hardware problem. I didn't understand why the sketch works at the Teensy 3.2 but not at the 4.0. I don't know how to fix it.

Best regards

Markus