Guiding Problems with PHD2 and OnStep


the.cakemaker75@...
 

I am a complete newbie here and i got me a OnStep controlled EQ5 from a barter.
The System works very well but i have an issue, i do not understand clearly, because i did not program anything of the system on my own...

The system is:

EQ5 with OnStep Control System
Canon 5DIIIa on a Samyang 135mm
ASI120 guidecam on a SVBony 30mm guidescope
Mini Stick PC with Windows that Runs N.I.N.A and PHD2
The ASI guidingcam is NOT connected via ST4

Allright. first of all, the system starts, and connects flawless, everything works perfect.

I can slew to my object, platesolve , and use every feature of N.I.N.A. without any problems.

The problems start when it comes to guiding...

So when i am at my object, the plans for pictures are configured and running i start guiding in PHD2

NOW there are two scenarios, but both have the same problem.

Scenario 1:

I have a working calibration and start with the magnifiying glas icon to choose a bunch of guidestars. works. 
Now i hit guiding and then  - STAR LOST
And i can see the problem immideatly. The first guiding pulse moves the mount so far, that the guidestars are too far from there startingpoint.
That means, that the step is too big so the stars get lost, i can clearly see that. 
Changing the searching region CAN help from time to time, but most of the time the move is also too big for this.

Scenario 2:

No working calibration - same step. Choose star, hit start. In this scenario the star gets lost at the same time, because calibration moves to strong...

Now i looked for the modes of guide rate and pulse guide rate and found out that i can change them on the handbox.

On the handbox, right after starting the system from no power, the display always starts with the letter 20X on the left top.
I found out that this is the "guidespeed" I do not understand what that means, because it obviously is NOT the guidespeed...
The guidespeed is shown in the menu "pulse guide speed"
Anyways. I change the guidespeed to 1, because there is no lower rate.
After that i change the pulseguidespeed to 0.5, a setting that always worked for me on my other systems.
Sometimes i managed to get the system running this way, sometimes not...
I have no idea what exactly i am setting here and am searching desperately for a good explanation of this part of the controlsystem, but most of the time a lot gets lost in translation...

It seems that the guidesignals somehow get multiplied somewhere somehow...

And what i also do not understand why the guiderates are always reset to 20x after a coldstart...

Maybe someone has an idea because atm i can NOT use the system just because guiding does not work for me.

Or maybe even provide me with a link to a good explanation of how this OnStep System works on softwareside.

Thanks so far
Niki


Derek Regan
 

All within PhD you can increase the box size that surrounds the star... Calibration is all about what size guide pulse to send to move the guidestar a certain distance.. that's why you calibrate... Where are you calibrating? For pulse guiding you need to calibrate on the equator, Dec 0... Are you northern hemisphere?


the.cakemaker75@...
 

Hi! 

I am calibrating wherever i am looking at. So most of the time near the object i plan to photograph. With my other two mounts (Skywatcher) this always worked flawless. I AM northern hemisphere, yes. I know that the box size can be changed in size, but even the largest wood be far to small for the initial move. 

I managed to capture a video of the LARGE move the first pulse does, so you can see. 



 

Niki,

I use an EQ5 as well with an ASI120 (though on a 50mm SVBony guidescope).  I will go through my workflow for guiding:

- Polar drift align in PHD2 (be sure tracking is ON when doing this)
- 3 Star align in OnStep
- Run PHD2 and point the scope or camera to an area of the sky at +/- 20 deg in declination (this is what PHD2 suggests)
- Move the scope to the desired target and begin guiding, letting PHD2 automatically detect the guide star AND the exposure

A few things for you to check based on your problem
1) Did you set the correct guidescope focal length and camera pixel size in PHD2?
2) You mention this works well on a Skywatcher mount...does your EQ5 have significant backlash in either DEC or RA?
3) Are you doing guiding via WiFi or hard-wired from your computer to the OnStep board?

According to the WIKI, the pulse-guide command is always 0.25x, 0.5x, or 1.0x and never higher.
  1. With this separate pulse-guide rate any rate set at 0.25x, 0.5x, or 1x applies to both the normal guide rate and the pulse-guide rate.  Any rate set above 1x is applied to the normal guide rate only and the pulse-guide rate will remain at the last setting (0.25x, 0.5x, or 1x.)


Howard Dutton
 

A good summary Otto.

I would add that versions of OnStep prior to the current release-4.24 (that is, anything earlier than version 4.24q) may have a bug where the variable guide rate guide commands (and spiral search) trip up pulse guiding.  That was patched back in March.

If you don't want to update to the latest, the solution is to be sure you set the guide rate (perhaps 0.5x) just before guiding starts.

This could really be incorrectly set backlash too, the above is just a possibility.


Pablo Lewin
 

Do you have the PEC correction on? if so TURN IT OFF! I had a similar problem with my CGE Pro and I couldn't understand why the stars/mount would jump around..then I turned the PEC off and voila!..try it...even if it's not the problem, it's one less variable to deal with till you find what's wrong..

Pablo Lewin
The Maury Lewin Astronomical Observatory
Glendora CA. USA.


Derek Regan
 

So you're using a ST4 cable to the mount?  
The video shows a box far too small for the guide pulse, not so sure that you can decrease the pulse but you can increase the box in size... If it works on your other setups then something is different,either calibration step size, guide pulse size, something like that..don't think it has anything to do with Onstep, more PhD setup


Derek Regan
 

It also shows you selecting the star, let PhD choose... Can't really see on the video but did it lose the star on the first guide pulse? As the first calibration step on my setup is fairly small, sure the guide pulse increase as the steps do..


the.cakemaker75@...
 

Hey! Time to answer now finally... 

Wanted to give all your kind suggestions a try tonight but clouds...

I align with the new Alignment routine of N.I.N.A. now, because it is way faster then the drift alingnment of PHD2, just for info
I do NOT make a 3 Star alignmet, because i platesolve so this is imho useless for me.
Guidescope indeed was entered wrong some time ago but ist is right now.
I DO have a VEEERY Big Backlash in DEC that i was NOT able to get away atm.
I guide via the Stick PC thats mounted right on my mount so, NO, i do not have a problem with delay over WIFI. The Control Computer goes with the scope...


the.cakemaker75@...
 

Hello Mr Dutton!

I am not used to programming the system, since i did not build it on my own. 
I have to check what version i run and will see if this triggers my problem.
I do think that the backlash correction you mentioned could be the main problem, becaus i DO have big backlash in dec and managed to measure that and program a correction in PHD. Maybe this correction is still active and causes problems.

I DO check guide rate all the time by now...


the.cakemaker75@...
 

Pec correction is OFF


the.cakemaker75@...
 

Hey"!

No i do NOT use a ST4 cable. The box size is as it is with all my other mounts. I did try to make it as big as possible, but the movement was too big for the largest box too...

I will look after PHD2 settings more exact. Thanks for the information.


the.cakemaker75@...
 

I did i wrong, when i recorded the video, because i did not know that the magnifying glass icon lets PHD select the star (and multistar guiding) at that time
I do let PHD select the stars atm.

And Yes, star lost on first guide pulse.

What is certain is, that the pulses are FAR to large. I have to find out why... 

I think like Howard Dutton mentioned, maybe it has womething to do with backlash compensation...


Chris Whitener
 

Phd2 has several tools to check the mount.
Usually movements that are too short or long are because the pulse runs into mechanical looseness.  A loose movement is called backlash by astronomy folks.  Imagine the following.  A declination that has slop in it.  The first movement may tumble it forward.  Or lose it if backward.   

Try the full phd2 test including the 2 minute backlash test.  It tells a lot.


Derek Regan
 

So if you're pulse guiding, then you should be calibrating on the equator, Dec 0/ meridian intersection, if you're northern hemisphere then point it south, click on the drift tool and get the Dec on 0( altitude) and the azimuth as close to 0 as you can but depends on what side of pier it is... X the drift tool out and then calibrate.. if you check the box in the settings you won't need to re calibrate everytime you setup or switch targets as you do with ST4...  
The instructions are in PhD, nothing to do with Onstep


the.cakemaker75@...
 

Managed to run the guiding assistant the other day. Don’t remember how, but it worked. Thats QHY i know that there is big backlash in dec. But i did not manage to solve that yet. It is a bit better now but not solved yet. I have some pictures here. 


the.cakemaker75@...
 

So tonight is training night. Disassembled my dec axis completely, without recognizing an obvious fault. I cleaned it and greased it new, reassembled and tried tonight.
Thit the polaralignment via NINA´s three point polalign. You see that this fits quite good on the screenshot.
The same large "jump" happened when trying to calibrate. 
Running out of ideas i found out, that setting the calibration steps to 5! instead of something like 1800 solves THIS problem. 
The guiding assistent though still measures a HUUUGE backlash in dec that i just can not understand. 
I set that up yesterday and there really is NO significant backlash in dec....
I run the guiding assistant of PHD now, and when it comes to backlash measuring the star wanders out of the field and the measuring stopps...
I have lots of screenshots here so you can see.
I do not understand what is measured wrong here or what the problem is...


the.cakemaker75@...
 

Here you can see how the backlash measuring goes wild...


the.cakemaker75@...
 

Dont know how to modify my messages. 
Finally i think all of you are right thinking that the problem is phd2
Going to search PHD2 groups for a solution.
Thanx so far.


the.cakemaker75@...
 

Hello!

I don´t know if anyone is still following here, but i did a few tests in the meanwhile.
In the PHD2 group i was told to uninstall, reinstall and all that stuff, but nothing worked.
So i decided to do aanother test. I tried using my MGen2 for guiding. If that would work, PHD2 would be the problem.

And guess what? The MGen2 did the same strange calibrating "jumps" like PHD2 did...

This STRANGE behaviour can be only explained via a setting in ONstep...

Again i ask you. WHY do the calibrating steps seem to be "multiplied" by the OnStep control? 
Where can i find these settings? 
Again said, when i set the calibration steps to something like 5-10 i CAN calibrate...
Another funny thing is that when i do the polar alignment in N.I.N.A. to an almost PERFECT alignment, PHD measures an alignment, thats really bad.
Also i get a backlash meaured, that is REALLY not there at all....

Are there really no ideas, what this annoying behaviour is coming from?

cheers, Niki...