Setting the tracking rate


Merowinger
 

Hi all,


I am still learning to interface/use my brand new OnStep-Controller, build with the STM32 Blue Pill, F103. After first unsuccessful steps, I have some questions maybe someone knows the answer:

This is my setup:

EQ-6 mount
RaspberryPi running IndigoSky
Connected using devUSB0 to OnStep

I additionally connected using the OnStep-App on my phone, there I can see and control everything, park, unpark, goto. All seems to work.

I found the buttons to adjust the tracking rate, I tested it, but rate did not change, the rate is always 60.164 Hz in sidereal. Is there a configuration switch to disable this feature? I disconnected the IndigoSky by disconnecting the USB cable, but the behaviour is always the same. The rate does not change!

Someone knows the answer?


Best regards

Frank


Merowinger
 

I am just thinking about this:

If the EEPROM on the DS3231 is not working properly, will this result in the behaviour? How can I test the EEPROM?


Frank

Am 14.05.2022 um 10:31 schrieb Merowinger:

Hi all,


I am still learning to interface/use my brand new OnStep-Controller, build with the STM32 Blue Pill, F103. After first unsuccessful steps, I have some questions maybe someone knows the answer:

This is my setup:

EQ-6 mount
RaspberryPi running IndigoSky
Connected using devUSB0 to OnStep

I additionally connected using the OnStep-App on my phone, there I can see and control everything, park, unpark, goto. All seems to work.

I found the buttons to adjust the tracking rate, I tested it, but rate did not change, the rate is always 60.164 Hz in sidereal. Is there a configuration switch to disable this feature? I disconnected the IndigoSky by disconnecting the USB cable, but the behaviour is always the same. The rate does not change!

Someone knows the answer?


Best regards

Frank






Drew 🔭📷🚴‍♂️
 

On Sat, May 14, 2022 at 04:31 AM, Merowinger wrote:

I found the buttons to adjust the tracking rate, I tested it, but rate did not change, the rate is always 60.164 Hz in sidereal.
There is a common misperception as to what the buttons do and what the tracking rate is showing. The tracking rate is reporting the requested tracking rate. The heavens move at 60.164 Hz, change it to Lunar, and it will report the 57.xxx (I don't remember the exact number) rate requested to track the moon.

The tracking rate buttons adjust the master clock to correct for errors in the board clock. Some MCU's have inaccurate clocks, some do not.  The STM32 is not bad (ASIK) and should not require adjustment. PPS will improve the accuracy to as good as you can get.

If you are experiencing drift, look at the stepper math first. A one-step error can generate a huge amount of drift.


Mike Ahner
 

On Sat, May 14, 2022 at 07:31 AM, Merowinger wrote:
If the EEPROM on the DS3231 is not working properly, will this result in the behaviour? How can I test the EEPROM?
Because the STM32F103/303 micros do not have onboard EEPROM, if the DS3231 isn't working, OnStep won't boot.

There are some test utilities in the Files section under STM32, there is one specifically for testing the EEPROM.
https://onstep.groups.io/g/main/files/Utilities%20for%20STM32

With the Blue Pill, normally you will not need to change the master clock, the Blue Pill is fairly accurate. But enable PPS in the Config.h file and OnStep will correct the clock with the temperature-compensated RTC of the DS3231.

-Mike


Merowinger
 

Thanx Drew for the answer, I activated PPS and I will continue setting up my system :-)

Next thing I learned is that the RA-motor is running wrong direction :-) I had to configure to invers. The DE-motor seems to be ok :-) (I did not understand in the moment, why only one of the motors must be inverted, both are wired identically, but ok, I will see if guiding works.)

Am 14.05.2022 um 15:55 schrieb Drew 🔭📷🚴 ♂:

On Sat, May 14, 2022 at 04:31 AM, Merowinger wrote:

I found the buttons to adjust the tracking rate, I tested it, but rate did not change, the rate is always 60.164 Hz in sidereal.
There is a common misperception as to what the buttons do and what the tracking rate is showing. The tracking rate is reporting the requested tracking rate. The heavens move at 60.164 Hz, change it to Lunar, and it will report the 57.xxx (I don't remember the exact number) rate requested to track the moon.

The tracking rate buttons adjust the master clock to correct for errors in the board clock. Some MCU's have inaccurate clocks, some do not.  The STM32 is not bad (ASIK) and should not require adjustment. PPS will improve the accuracy to as good as you can get.

If you are experiencing drift, look at the stepper math first. A one-step error can generate a huge amount of drift.


Merowinger
 

Thanx Mike, I will check this out :-)


Am 14.05.2022 um 18:38 schrieb Mike Ahner:

On Sat, May 14, 2022 at 07:31 AM, Merowinger wrote:
If the EEPROM on the DS3231 is not working properly, will this result in the behaviour? How can I test the EEPROM?
Because the STM32F103/303 micros do not have onboard EEPROM, if the DS3231 isn't working, OnStep won't boot.

There are some test utilities in the Files section under STM32, there is one specifically for testing the EEPROM.
https://onstep.groups.io/g/main/files/Utilities%20for%20STM32

With the Blue Pill, normally you will not need to change the master clock, the Blue Pill is fairly accurate. But enable PPS in the Config.h file and OnStep will correct the clock with the temperature-compensated RTC of the DS3231.

-Mike