4.24q will not run


I am using 4.24q on a MAXSMT3.6 board. When I flashed the blackpill it worked ok 1st time. When I tried to flash again because of problems with my motors the port on arduino was greyed out and it failed to upload.. It took me several retries before it flashed again. It flashed even though the port selction was greyed and was previously set to the port used when just powering up the controller without pressing bootload and reset. No idea why it flashed the second time finally as I had tried about 7 times unsuceesfully.

Jamie Flinn

Additional info - Tried turning on DEBUG to view via serial monitor and found that there is not even a port being created - so the FW is actually not initializing? - is is possible there is a need for some new library in arduino for this version - this issue is extremely low level - please advise especially if you have an S6 board and are running 4.24q - did you need to update arduino or some other library perhaps in DFU or in STM32CubeProgrammer between 4.24K and 4.24q????