web server ( including smart web-server) and com port conflict in windows 10


Plamen Dimitrov
 

Hello everyone,
I've got few MaxEsp3 controllers and recently found a problem: One of my controllers (MAXESP3) is connected to windows 10 machine  so I can use TheSkyX installed there as well as MaximDL.The controller is connected via usb cable to a free com port on windows computer. The computer can control MaxEsp3 ( version 4.24) and  ( both TheSkyX and MaximDL worked well including a focuser on Com3 port. However, when the usb cable is connected to the computer- the web server version 2.1 v crashes. Screenshots are attached.
On the spare controller  MaxESP3 I installed OnStep 10.08 e and smart web server 2.04f. In this occasion the web server do not crash but became unstable leading tho computer freeze. Screen captures are included.
Of course, I can choose the option not to use the web server, but it is handy for Finding Home,- an option which is not available in my TheSkyX version.
My simple question is: how to fix this issue and make the web server not to crash? All baud rate used are the default values as suggested in both config.h (OnStep and Web servers) files and haven't been changed.
Any help is appreciated.


Howard Dutton
 
Edited

On Sun, Sep 18, 2022 at 03:01 AM, Plamen Dimitrov wrote:
the web server version 2.1 v crashes. Screenshots are attached.
The SWS isn't crashing, apparently OnStep is crashing.

Likely this is due to some instability from plugging in that USB cable.  Why this would be I can't say but there are lots of users and this is the first time I recall seeing this.

Perhaps try another power supply and/or review the soldering on the board.


Howard Dutton
 

If the problem persists you could always prepare a dedicated USB cable with the 5V wire cut and see if that works.


Plamen Dimitrov
 

Thanks Howard,
more likely as you mentioned should be the usb connection.
When I tried on a Mac than OnStep 4.24 didn't crash but Onstep 10.08 still does. Thanks for the suggestions. Will report the result.

Thanks

Plamen


Plamen Dimitrov
 

I haven't tried dedicated usb and will do asap. However, here is something I tried which was unexpected: I've got still operational my first 2 OnStep controllers based on 1) STM32 ( Web Server 2.1j, OnStep 4.23g)  and 2) MKS_Gen_L2 ( ( Web Server 1.14, OnStep 5.1v). The unexpected is that when connected to the same Windows 10 machine ( where MAXESP3 problems were detected)  no crash was detected even when connected to TheSkyX and MaximDL on the run).
By the way I build windows 10 Virtual machine ( as a clone of my Windows 10 computer) on my mac and there MAXESP3 didn't crash.
Of course, I don't have enough knowledge to explain this.
I can use VM but the only problem is - VM on Mac Book Pro is using a lot of energy from its its battery.
So, I will use a dedicated cable as final test and will report.

Plamen


Peter Boreland
 

Plamen, as an aside, where did you download smart web server 2.04f? Do you have a link please?

Peter


Mesquita
 

Plamen, as an aside, where did you download smart web server 2.04f? Do you have a link please?

Peter


Dave Schwartz
 


On September 19, 2022 6:26:12 p.m. EDT, "Peter Boreland via groups.io" <pcboreland@...> wrote:
Plamen, as an aside, where did you download smart web server 2.04f? Do you have a link please?

Peter
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.


George Cushing
 

Google "Smart Web Server."


Plamen Dimitrov
 

Thanks everyone for the support,
I solved the problem. I installed wrong  driver for CP21XX . My mistake was in windows 10 I supposed to use the universal driver but I used their driver for windows 7 and 8.
Thanks
Plamen