ASCOM interface sluggish.


Robert Benward
 

Hi All,
I am having a heck of time getting my ASCOM hub working.  I finally got it to do something, but I keep getting message like the ones below that I fail to open a client socket.  I am trying to run a PHD calibration, and it extremely sluggish,  Everything seems to be timing out.  The SWS seems to connect immediately, but my Sky Safari takes forever to connect, and it seems I am having the same issue with ASCOM and PHD.  The IP address comes up as 192.168.50.55:9999.  I assume the 9999 is a port.  Do I need to do something on my network ease traffic to the Onstep? I also see that the Sky Safari does not like it when the SWS is active, it will disconnect on it's own, and then refuse to reconnect without reboot the Onstep.  FYI, my ASUS router came default at 192.168.50.1.
Any ideas?

Thanks,
Bob

20:20:10.189: Telescope - Statuses:     Get RightAscensionRate: 0
20:20:31.231: Telescope - Statuses:     Get SideOfPier Exception: SendMessageIP failed: opening client socket to 192.168.50.55:9999
20:21:13.328: Telescope - Statuses:     Get SiderealTime Exception: SendMessageIP failed: opening client socket to 192.168.50.55:9999
20:21:53.459: Telescope - Statuses:     Get Slewing Exception: SendMessageIP failed: opening client socket to 192.168.50.55:9999
20:22:14.504: Telescope - Statuses:     Get TargetDeclination Exception: TargetDeclination get - no value has been set.
20:22:14.504: Telescope - Statuses:     Get TargetRightAscension Exception: TargetRightAscension get - no value has been set.
20:22:35.551: Telescope - Statuses:     Get Tracking Exception: SendMessageIP failed: opening client socket to 192.168.50.55:9999
20:23:17.654: Telescope - Statuses:     Get TrackingRate Exception: SendMessageIP failed: opening client socket to 192.168.50.55:9999
 


 

I don't know which build you are using, but take a look at this thread. The easiest way is to take Wemos out and flash it through it's micro USB port.

Make sure ESP8266 library v2.4.2 is used (in board manager). Newer libraries causes similar issues which results in instabilities just as you described.

  • In boards select Generic ESP8266 Module
  • Flash Mode: "DIO"
  • Erase Flash: "Sketch + WiFi Settings"
  • Flash Size: "1M (64K SPIFFS)"
  • Reset Method: "ck"
  • Upload Speed: "115200"

Make sure to use this SWS (not the one from addon folder)
Make sure Wemos is in bootloader mode while flashing SWS (pin D3 must be shorted to GND while flashing SWS)
Make sure MCU UART which you use to connect Wemos to operates at same baud rate as Wemos (set them all to the same value).
Check your PCB diagram to find out which pinout it's use and disable swapped pins
If You have custom build, do not use UART0 which is normally used by MCU's USB serial.


Robert Benward
 


So this is what I have installed (version 3.0.0).  Should I change the version to 2.4.2? and reload?



Ken Hunter
 

Yes... In lower Left corner select the 2.4.2 version and click install. The 2.4.2 will overwrite the 3.0.0.
Close and re-open the .ino file and try again.


Robert Benward
 

Well Gentlemen, so far so good!  All these little details!

Interesting how the upload messages look completely different.

Thanks again,
Bob


Robert Benward
 

Vladimir, Ken,
Vladimir, you were right on target.  I was running until midnight and then shutdown.  I restarted this morning and everything connected promptly except for Sky Safari.  The ASCOM Hub, then PHD2, APT, and eventually, Sky Safari.  All connected without complaints or error messages.  It seems like Sky Safari still wants to search all over the internet for a connection to my scope, but it does get there eventually. 

Thanks again!