Blue pill to Black pill


robert utecht
 

Hi Group I have a Blue pill with a Black pill update when I try to Flash the Board its given me an Error: no debug  probe detected what do I need to check.


Thank You.

 Robert    


Glenn Sammes
 

The Arduino connection needs to be serial  on COM X in the connection area.. No probe detected implies the upload mode is set to an STM USB programmer.

 

From: main@onstep.groups.io <main@onstep.groups.io> On Behalf Of robert utecht
Sent: Tuesday, 4 May 2021 10:19 AM
To: main@onstep.groups.io
Subject: [onstep] Blue pill to Black pill

 

Hi Group I have a Blue pill with a Black pill update when I try to Flash the Board its given me an Error: no debug  probe detected what do I need to check.


Thank You.

 Robert    


Dave Schwartz
 

Did you select the upload method 'STM32CubeProgrammer (Serial)'?

On 2021-05-03 6:18 p.m., robert utecht wrote:
Hi Group I have a Blue pill with a Black pill update when I try to Flash the Board its given me an Error: no debug  probe detected what do I need to check.


Thank You.

 Robert


robert utecht
 

Yes I did I ran the STM32CubeProgramer for Serial, first and then went to open Arduino and then tried to flash

Robert 


On Mon, May 3, 2021 at 6:50 PM Dave Schwartz <Dave.Schwartz@...> wrote:
Did you select the upload method 'STM32CubeProgrammer (Serial)'?

On 2021-05-03 6:18 p.m., robert utecht wrote:
> Hi Group I have a Blue pill with a Black pill update when I try to
> Flash the Board its given me an Error: no debug  probe detected what
> do I need to check.
>
>
> Thank You.
>
>  Robert
>






Dave Schwartz
 

You don't run the STM32CubeProgrammer directly, The Arduino IDE runs it for you but you have to tell it what mode to run it in. That's done with the upload method under the tools menu


On May 3, 2021 8:14:42 p.m. EDT, robert utecht <robertutecht@...> wrote:
Yes I did I ran the STM32CubeProgramer for Serial, first and then went to open Arduino and then tried to flash

Robert 


On Mon, May 3, 2021 at 6:50 PM Dave Schwartz <Dave.Schwartz@...> wrote:
Did you select the upload method 'STM32CubeProgrammer (Serial)'?

On 2021-05-03 6:18 p.m., robert utecht wrote:
> Hi Group I have a Blue pill with a Black pill update when I try to
> Flash the Board its given me an Error: no debug  probe detected what
> do I need to check.
>
>
> Thank You.
>
>  Robert
>






--
Sent from my Android device with K-9 Mail. Please excuse my brevity.


robert utecht
 

Well getting closer  Now it telling me  Timeout error occurred while waiting for acknowledgment  error Activation device: KO please verify the boot mode configuration  and cherak the serial port configuration  reset your device and try again I know the blue pill and the black have different boot jumpers and how do I reset my device?.

Robert   

On Mon, May 3, 2021 at 8:32 PM Dave Schwartz <Dave.Schwartz@...> wrote:
You don't run the STM32CubeProgrammer directly, The Arduino IDE runs it for you but you have to tell it what mode to run it in. That's done with the upload method under the tools menu

On May 3, 2021 8:14:42 p.m. EDT, robert utecht <robertutecht@...> wrote:
Yes I did I ran the STM32CubeProgramer for Serial, first and then went to open Arduino and then tried to flash

Robert 


On Mon, May 3, 2021 at 6:50 PM Dave Schwartz <Dave.Schwartz@...> wrote:
Did you select the upload method 'STM32CubeProgrammer (Serial)'?

On 2021-05-03 6:18 p.m., robert utecht wrote:
> Hi Group I have a Blue pill with a Black pill update when I try to
> Flash the Board its given me an Error: no debug  probe detected what
> do I need to check.
>
>
> Thank You.
>
>  Robert
>






--
Sent from my Android device with K-9 Mail. Please excuse my brevity.