Topics

Help! Runaway slewing

biggs@...
 

My OnStep won't stop slewing once started.  I'm using v4.7i on a Mega2560 and was operating fine.
First happen with Ekos, but same result from Sky Planetarium.
I switched off power to the motors so the scope is safe, but it just keeps going.  No limits are observed.

Any suggestions before I purge the firmware and EEPROM?

Thanks!

Howard Dutton
 

Tell me about the ST4 port settings.

Howard Dutton
 

On Sat, Jun 27, 2020 at 11:30 AM, Howard Dutton wrote:
Tell me about the ST4 port settings.
And what is or is not attached to the port pins.

biggs@...
 

There is no ST4 used.  It uses the Classic pinout with GENERIC2 setup.
OnStep is stuck driving at max slew and nothing will stop it.
Thanks.

Howard Dutton
 

Post the Config.h file please.

Serge CLAUS
 

Hello,
I think I had an identical problem a few days ago.
I use an MPU9250 (9DO accelerometer) with a Wemos attached to the telescope to know the position of the telescope.
If the limits are exceeded, it switches the LIMITS pin of OnStep to the low state.
I wanted to park the telescope but it went down much lower than expected.
Possible that the known position of OnStep and the actual position were incorrect.
My limit system started working, but the telescope continued to descend.
I had to cut the 12V to stop it.
I thought that the stop order had not been transmitted (a bad contact between Wemos and OnStep?).
I checked my wiring and did a test.
By lowering the telescope manually, the tracking stopped well.
Maybe this is another problem then. At park time?
I am using an Arduino Mega + Ramps 1.6+ with the latest master version.
Indi 1.8.5 + CCDCiel

biggs@...
 

Config.h attached.

I think it is a Parking issue.  It might think it is parked but still slewing.
I believe the last valid command was either a Park or Home.  I was trying to get to Polar position.
The coordinate at +90 deg is suspicious.

How do I wipe the EEPROM?

Thanks.

Howard Dutton
 

On Sat, Jun 27, 2020 at 01:39 PM, Serge CLAUS wrote:
My limit system started working, but the telescope continued to descend.
I had to cut the 12V to stop it.
I thought that the stop order had not been transmitted (a bad contact between Wemos and OnStep?).
I checked my wiring and did a test.
Did you get an "Error: Limit sense"?

Howard Dutton
 
Edited

On Sat, Jun 27, 2020 at 02:07 PM, <biggs@...> wrote:
Config.h attached.
Thank you.  I was wondering about a couple of things and it's a lot quicker than asking/answering several questions.  None of what I was worrying about applies.

I think it is a Parking issue.  It might think it is parked but still slewing.
There is no code to allow something like that after a power cycle.  A park is a kind of slew and slew "state" isn't saved in EEPROM.

I believe the last valid command was either a Park or Home.  I was trying to get to Polar position.
The coordinate at +90 deg is suspicious.

How do I wipe the EEPROM?
I would rather you download the latest master branch...

Then set (near the top of OnStep.ino):
#define DEBUG_ON

Open the Serial Monitor (at 9600 baud) so you can see the serial output immediately at boot-time then upload the sketch and let me know if anything is displayed.

This latest version validates most of the values coming out of EEPROM so if something is far out of range it will probably let you know.  It will also reset the parameter to the default value or constrain the range as appropriate so things might even just magically start working correctly again.

If the above doesn't work you can wipe the EEPROM with...

Follow the instructions near the top of OnStep.ino to wipe the EEPROM/NV memory, be sure to turn both of these options off when finished.

If none of this works I'll get out a Mega2560 and check it with your Config.h.

Probably the next thing I'll do to help speed up debugging issues like this is add a NV dump command to OnStep so I can get a copy/paste of your exact EEPROM contents for better 1:1 testing here.

Howard Dutton
 

On Sat, Jun 27, 2020 at 03:12 PM, Howard Dutton wrote:
This latest version validates most of the values coming out of EEPROM
It is also my intention to check for and log other errors (command and parking for example) using this system.  And also, optionally, to log non-error events via #define MESSAGE_LOG_ON.

If the debug serial channel is directed at an unused serial port faster OnStep's (Teensy's etc.) could leave this enabled at all times to alert the user of trouble.

biggs@...
 

Hi Howard,
I was able to get back out to the scope.  The Debug mode didn't output anything.  The problem is repeatable.  Reset Onstep, start Tracking, Slew RA, RA doesn't stop.
I'm attaching the ASCOM log of doing this, and my own dump of the EEPROM contents.

Hope this helps.  I'll erase the EEPROM next chance I get.

Thanks,
David

Howard Dutton
 

On Sun, Jun 28, 2020 at 09:46 PM, <biggs@...> wrote:
Reset Onstep, start Tracking, Slew RA, RA doesn't stop.
It would be good to know for sure what "Slew RA" means.  I assume you mean you start a guide in RA?

biggs@...
 

For clarification, In Sky Planetarium,  I connect to Onstep, start Tracking, then in Controls, set the Slew Rate to VVF, and click and hold W or E. Releasing click and the RA motor keeps going.
Did the same in ASCOM Device Hub.

Howard Dutton
 

On Mon, Jun 29, 2020 at 09:09 AM, <biggs@...> wrote:
For clarification, In Sky Planetarium,  I connect to Onstep, start Tracking, then in Controls, set the Slew Rate to VVF, and click and hold W or E. Releasing click and the RA motor keeps going.
Did the same in ASCOM Device Hub.
What are the connection settings in the ASCOM driver.  Serial or IP, error correcting protocol?

biggs@...
 

Serial.

Howard Dutton
 

I think I might understand the problem...

In Sky Planetarium press the [Home (Reset)] button and see if things start working properly.

biggs@...
 

I clicked Home and it briefly started working correctly.  Then the problem returned, so I reset the EEPROM.  And the problem returned.
So I gave up and went back to my older v2 copy of Onstep and it worked properly.  Not sure what else to do.

Howard Dutton
 
Edited

On Tue, Jun 30, 2020 at 11:12 AM, <biggs@...> wrote:
I clicked Home and it briefly started working correctly.  Then the problem returned, so I reset the EEPROM.  And the problem returned.
So I gave up and went back to my older v2 copy of Onstep and it worked properly.  Not sure what else to do.
That pressing Home was a test, not a fix.  The latest master branch (and release-3.16) are patched against what I think the issue is now.  Nothing in your description of the steps taken above excludes the possibility of this working.  Since I can't replicate the problem here I can't be sure though.

biggs@...
 

I was able to get back to testing.  For some reason the DEBUG ON version wouldn't compile from the latest code, but the regular compile worked fine last night.  I'll watch out for further issues.  Thanks.

Khalid Baheyeldin
 

On Tue, Jul 7, 2020 at 02:25 PM, <biggs@...> wrote:
For some reason the DEBUG ON version wouldn't compile from the latest code, but the regular compile worked fine last night.
Are you getting errors or just warnings?

I do get warnings if I have this in my Config.h file:

#define DEBUG ON
(Or VERBOSE, same behaviour) ...

The warnings are:

In file included from sketch/Config.h:247:0,
                 from ../projects/OnStep/OnStep/OnStep.ino:66:
sketch/MyConfig.h:4:0: warning: "DEBUG" redefined [enabled by default]
 #define DEBUG ON
 ^
/home/kbahey/projects/OnStep/OnStep/OnStep.ino:59:0: note: this is the location of the previous definition
 #define DEBUG OFF             // default=OFF, use "DEBUG ON" for background errors only, use "DEBUG VERBOSE" for all errors and status messages

But you can safely ignore the warnings, and proceed as usual.