Topics

MaxPCBv2 wemos d1 can't connect to controller


Harry Wu
 

Hello, I've posted this question before and I searched every article and nothing's change.
I am using MaxPCBv2, teensy 3.6, wemos d1 mini pro,
I can compile both teensy and wemos, when I plug wemos in the pcb, wemos d1's blue LED still flashing not still, SSID is ESP_F4E5DF,
I know this shows wemos is not connected to the controller,
I've checked teensy's RX TX and wemos' D7 D8 with multimeter, the soldering is fine.

Here's my Onstep's config.h and wifi's config.h,

Please help me to fix this problem.


Thank you all


Drew 🔭📷🚴‍♂️
 

Please post your WiFi.ino also so I can see what version you are using, etc. What version of OnStep do you have?

Have you tried flashing the Wemos with erase option set to all? If not try flashing  the Wemos with full erase set in the hardware options of the Arduino IDE. This often solves problems like yours.


Harry Wu
 

Drew, I've posted my WiFi.ino, I'm using OnStep 3.16.

I have try to erase all and reflash again, nothing's change.
I switch to another wemos d1 and it didn't work either.


Drew 🔭📷🚴‍♂️
 

There is something wrong with the WiFi.ino upload. It's like it is in html format or something. Your other files where fine. Please upload it again.


Harry Wu
 

I made no change to WiFi.ino and upload it again, wemos LED is still flashing, not connected to the controller.
Do I have to change anything in WiFi.ino?
I saw some old articles said that there was an option called "serial_swap", but I can't find this line in OnStep and WiFi's config.h,
do I have to add this line on my own?



Thanks


Harry Wu
 


This is my board's picture, is there anything I didn't solder it or connect it?






Drew 🔭📷🚴‍♂️
 

Yes! You show a Wemos pro without an antenna. The little copper colored socket on the lower left corner is the antenna connector. Do you have the antenna? Without it you cannot connect. Still it seems that this is not your problem.

My apologies. The file I need is WiFi-Bluetooth.ino (file structure is different in the Master). Please upload this file.


Harry Wu
 

I've plug the antenna and It still show ESP_F4E5DF not OnStep.
Drew, here's the WiFi-Bluetooth.ino, if you need anything please tell me.


Thank you.


Thomas Westerhoff
 

The sync process between WEMOS and the teensy is not optimally solved. In my case it sometimes takes a long time until a connection is established. Sometimes it takes up to a minute until I finally get a value from the encoders. They just try all kinds of baudrates until it works. You could simply set a defined baudrate on both sides and that would be much faster.
--
Thomas Westerhoff
Kirchheim Observatory /Germany
http://sternwarte-kirchheim.de/
https://www.facebook.com/VolkssternwarteKirchheim/


Harry Wu
 

Hello Thomas, can you be more specific about the baud rates?
which line should I set, from OnStep and WiFi addon's config.h?

Thank you.


Thomas Westerhoff
 

Here are both config.h for Onstep and Wifi and also a slightly modified WiFi.ino that works for me well. Please keep in mind that all the other settings in the config corresponds to my setup, especially the encoder and motor setting setting. 
--
Thomas Westerhoff
Kirchheim Observatory /Germany
http://sternwarte-kirchheim.de/
https://www.facebook.com/VolkssternwarteKirchheim/


Harry Wu
 

Thomas, here's the error message from WiFi addon, WiFi.ino's error message,
please take a look what's going on.
I've already modified both config.h except the encoder's part.


Thank you.


Drew 🔭📷🚴‍♂️
 

Thomas, he is using the 3.16 version, you are using the master. This may only confuse things, I know it does me.

Even with the auto baud rate I don't believe it should be going to the Wemos default SSID. Still, it is worth a try in case something is not sequential. That is, it is  bringing up the AP before it connects to OnStep. It is not supposed to do this.

Harry, sorry to ask for so much but could you post your OnStep.ino also? I am looking for specific version info, etc.


Thomas Westerhoff
 

Hello Harry. Your WiFi.ino is in the Wifi-bluetooth directory. if you use Arduino to compile it, the directory name should be the same as the .ino file  
Are you sure, you checked out the latest version from Github? Some months ago the "Wifi-bluetooth" directory was renamed to WiFi.
--
Thomas Westerhoff
Kirchheim Observatory /Germany
http://sternwarte-kirchheim.de/
https://www.facebook.com/VolkssternwarteKirchheim/


Harry Wu
 

Drew, here are the files I'm using right now, please take a look and if you need anything,
please do tell me, glad you can help!


Thank you.


Drew 🔭📷🚴‍♂️
 

On Wed, Dec 2, 2020 at 10:29 AM, Thomas Westerhoff wrote:
Some months ago the "Wifi-bluetooth" directory was renamed to WiFi.
Thomas, he is using the v3.16 "stable" version. It has a different file structure than the Master, it does use the "Wifi-bluetooth" directory.


Harry Wu
 

I'm using the latest version from Github.
In my addon directory there are two .ino "WiFi.ino" and "WiFi-Bluetooth.ino", your WiFi.ino seems to be my WiFi-Bluetooth.ino, I used it to program my wemos, it still showed many error massage like the one I gave you above.


Drew 🔭📷🚴‍♂️
 

Harry, just to be sure we are on the same "page" here. You were able to successfully compile and upload the OnStep code to the Wemos without any errors before?

BTW, I don't think  this has anything to do  with it but you should use the 115200 baud setting in the Arduino IDE hardware settings. The 57600 is just for OnStep.


Drew 🔭📷🚴‍♂️
 

On Wed, Dec 2, 2020 at 10:40 AM, Harry Wu wrote:
your WiFi.ino seems to be my WiFi-Bluetooth.ino,
This is the confusion between the Stable and Master version file naming. Do not use Thomas files directly, they cannot be substituted. Use them as a guide only.


Harry Wu
 

Drew, yes, I can compile both teensy3.6 and wemos successfully without any errors, and so do the files I just gave you.
Do you mean "Tools-Upload speed-115200"?