Onstep and ASIAIR works?


 

Hi,

Does anyone have tested the PCBMAX2 (Teensy 3.6) and PCBMIN (Teensy 3.2)  with the ZWO ASIAR?

Best
Andre


 

For that matter, has anyone used the AISIAIR (any version) with OnStep?


David Summa <dave@...>
 

Interested in this. So far, I’ve had no success using Air Pro.  Mount starts to slew (maybe 20 degrees) then stops.  Air reports it is continuing to move but it is not.  Initiating a Home command results in no motion but Air Pro reports normal movement.   I must reboot to get any motion again, but cycle repeats reproducibly.  ZWO has added the 2 telescope settings (OnStep Electronic and OnStep beta) but I have no success yet with either after trying all setting combinations.  

Regards,
Dave

On Oct 20, 2021, at 7:48 AM, Richard Shagam via groups.io <rnshagam@...> wrote:

For that matter, has anyone used the AISIAIR (any version) with OnStep?


"Guilherme Vênere
 

Wasn't there a bug in how ASIAIR/Ekos handled status updates from OnStep and got fixed in some newer version? I'm sure there are some messages about this in the group, I remember Khalid discussing it

Guilherme
 

On Wed, Oct 20, 2021 at 8:23 AM David Summa <dave@...> wrote:
Interested in this. So far, I’ve had no success using Air Pro.  Mount starts to slew (maybe 20 degrees) then stops.  Air reports it is continuing to move but it is not.  Initiating a Home command results in no motion but Air Pro reports normal movement.   I must reboot to get any motion again, but cycle repeats reproducibly.  ZWO has added the 2 telescope settings (OnStep Electronic and OnStep beta) but I have no success yet with either after trying all setting combinations.  

Regards,
Dave

On Oct 20, 2021, at 7:48 AM, Richard Shagam via groups.io <rnshagam=rhizotech.net@groups.io> wrote:

For that matter, has anyone used the AISIAIR (any version) with OnStep?


ybaransky
 

I believe I got it to work using the LX200 mount setting, but after playing around I did not pursue making it part of my workflow.  But I was using the instein branch of OnStep. Which is both old and different from the mainline. -yurij


Wagner Alves da Silva
 

I managed to connect and have Goto control, enable and disable tracking, return to starting position and also have controls for the buttons North, South, East West and speed of this command, I only need to test guidance and as soon as the weather improves here in Sao Paulo I will doing the test, the connection was by USB cable using the ubs serial that was recognized in the option (Onstep Electronics) I noticed that after we changed the USB module to CP2102 the Asiar system recognized the onstep perfectly, so I finished the guidance test and Asiar's polar alignment I will make a video and post to the group giving all information


David Summa <dave@...>
 

This is excellent news.  Thanks.  Can you add some detail:
- what usb speed are you using?
- what OnStep release are you running? 
Thanks
Regards,
Dave

On Oct 20, 2021, at 5:49 PM, Wagner Alves da Silva via groups.io <wasfelbr@...> wrote:


I managed to connect and have Goto control, enable and disable tracking, return to starting position and also have controls for the buttons North, South, East West and speed of this command, I only need to test guidance and as soon as the weather improves here in Sao Paulo I will doing the test, the connection was by USB cable using the ubs serial that was recognized in the option (Onstep Electronics) I noticed that after we changed the USB module to CP2102 the Asiar system recognized the onstep perfectly, so I finished the guidance test and Asiar's polar alignment I will make a video and post to the group giving all information