OnStep doesn't do meridian flip


Marco Cipriani
 

Hello,

For some reason, my OnStep board doesn't do the meridian flip when the time comes. It is connected to Sequence Generator Pro, which starts the meridian flip in the right moment, but OnStep doesn't do anything. It keeps tracking, until it goes 7° past the meridian and automatically stops tracking because of the limit I set in the OnStep ASCOM driver. I also tried setting the E/W limits to 30°, but the same thing happens. The overhead limit is set to 90°. During the last two nights, I tried doing the meridian flip a few times on different targets, but no luck... Also, after the mount limits are reached, OnStep stops responding to slews and manual movements, which means I have to power it off and home the mount manually, then restart OnStep (pretty tedious to do at 1 AM).

Any clue why the meridian flip doesn't happen? I attached my Config.h in case you want to see it. I'm using OnStep v4.24r.

Marco


Chad Gray
 

This is going to be a setting in SGP.  I dont use it often other than to support some of my customers.  

Check this document i made for Ekos/Kstars and see if you can find a setting in SGP that is analogous. 


On Sun, Jun 26, 2022 at 4:21 AM Marco Cipriani <marco.cipriani.01@...> wrote:

Hello,

For some reason, my OnStep board doesn't do the meridian flip when the time comes. It is connected to Sequence Generator Pro, which starts the meridian flip in the right moment, but OnStep doesn't do anything. It keeps tracking, until it goes 7° past the meridian and automatically stops tracking because of the limit I set in the OnStep ASCOM driver. I also tried setting the E/W limits to 30°, but the same thing happens. The overhead limit is set to 90°. During the last two nights, I tried doing the meridian flip a few times on different targets, but no luck... Also, after the mount limits are reached, OnStep stops responding to slews and manual movements, which means I have to power it off and home the mount manually, then restart OnStep (pretty tedious to do at 1 AM).

Any clue why the meridian flip doesn't happen? I attached my Config.h in case you want to see it. I'm using OnStep v4.24r.

Marco


Chad Gray
 

I think this is it in SGP.  You should get a count down timer in SGP when it is going to do the flip.

image.png


On Sun, Jun 26, 2022 at 10:27 AM Chad Gray <rchadgray@...> wrote:
This is going to be a setting in SGP.  I dont use it often other than to support some of my customers.  

Check this document i made for Ekos/Kstars and see if you can find a setting in SGP that is analogous. 


On Sun, Jun 26, 2022 at 4:21 AM Marco Cipriani <marco.cipriani.01@...> wrote:

Hello,

For some reason, my OnStep board doesn't do the meridian flip when the time comes. It is connected to Sequence Generator Pro, which starts the meridian flip in the right moment, but OnStep doesn't do anything. It keeps tracking, until it goes 7° past the meridian and automatically stops tracking because of the limit I set in the OnStep ASCOM driver. I also tried setting the E/W limits to 30°, but the same thing happens. The overhead limit is set to 90°. During the last two nights, I tried doing the meridian flip a few times on different targets, but no luck... Also, after the mount limits are reached, OnStep stops responding to slews and manual movements, which means I have to power it off and home the mount manually, then restart OnStep (pretty tedious to do at 1 AM).

Any clue why the meridian flip doesn't happen? I attached my Config.h in case you want to see it. I'm using OnStep v4.24r.

Marco


jak_kuehn@...
 

I am probably wrong, but I recal reading that you should have:

#define PIER_SIDE_PREFERRED_DEFAULT EAST

currently you have set to BEST.

I also think you need to set your limits (I think in the android app or smart webserver) to not track past the meridian although this might not be necessary. 0 degrees or 0 arcmins (I forget the units).When onstep hits the meridian it will stop tracking. I am not familiar with SGP but basically set a timer to occur after onstep has stopped tracking. Then send a goto command and it should do the meridian flip. If you have your settings to track past the meridian and your timer issues a goto command to that same object that is barely past the meridian it will stay on the same side or "best" side since it is permitted by the settings to say there. "Best" is good when your mount can go +/-10 degrees past meridian and you are viewing two objects lets say Jupiter and Saturn and Saturn just crossed the meridian. It is much nicer to not do a whole flip each time you switch between them. When you have set to "East" and your object is past the meridian, it should flip after a new command.

At least this is my understanding of how this works, I have not tried since reflashing my onstep to change to east.


Marco Cipriani
 

Thank you very much!