Topics

Onstep has no idea where stars are located


timtooley35@...
 

Hi,
I am new to Onstep, having recently installed the Bluepill STM32 version on an old Vixen GP Mount.
OnStep appears to have no idea of where the stars really are in the sky.
I slightly refined my Zero position after reviewing procedures to establishing the Home/Zero position for an EQ5 mount.. My original home position was certainly in the ballpark however.

I have used both the SHC to configure the time/date/UTC offset along with the site info for my Longiture/Lattitude which is near Raleigh, NC in the EST timezone. as well as multiple apps including the Onstep and SkySafari  apps to insure the correct date/time and site info were uploaded/set. And again all looks correct.
I even double checked the RA and Dec cables are plugged into the right ports!

When I power up the mount is in the Home position.

But, despite having what I think is all proper setup completed, when I tell it to goto an Alignment star the mount does not end up pointing even in the proper quadrant of the sky. In SkySafari you can see the scope moving across its star map and settles on the chosen star, so it thinks it has slewed correctly....but the scope is not even pointing in the right part of the sky.

Needless to say I am really puzzled.

Has anyone encountered such behavior and if so how did you resolve it?? This almost has to be user error on my part but I think I have covered all the bases.

Any ideas would be most appreciated!

Thanks,

Tim


Khalid Baheyeldin
 

On Mon, Nov 30, 2020 at 01:19 PM, <timtooley35@...> wrote:
when I tell it to goto an Alignment star the mount does not end up pointing even in the proper quadrant of the sky.
This could be several things:

- One axis, or both, need to reversed in Config.h (AXIS1_DRIVER_REVERSE and/or AXIS2_DRIVER_REVERSE need to be ON).
- Wrong steps per degree (AXIS1_STEPS_PER_DEGREE and/or AXIS2_STEPS_PER_DEGREE) that does not match your mechanical parameters.
- Wrong microsteps (AXIS1_DRIVER_MICROSTEPS and/or AXIS2_DRIVER_MICROSTEPS).

Let us start with where the mount points: is it in the wrong side of the meridian (pointing east instead of west)?


Mike Ahner
 

On Mon, Nov 30, 2020 at 12:19 PM, <timtooley35@...> wrote:
But, despite having what I think is all proper setup completed, when I tell it to goto an Alignment star the mount does not end up pointing even in the proper quadrant of the sky. In SkySafari you can see the scope moving across its star map and settles on the chosen star, so it thinks it has slewed correctly....but the scope is not even pointing in the right part of the sky.
One of your stepper motors, RA or DEC or both are running the wrong direction.
First, choose a star that you know where is located in the sky and watch the RA axis-- It should move in the correct direction to point the star. Then watch the DEC axis, same thing. My mount did that, I tried to point to a star in the East and instead it was point West and down toward the ground.

It's an easy fix, either swap wires of 1 of the 2 pairs or just change the direction in the config.h file. You can do that first then swap the wires if you wish or you can just do it in the software and leave it. I like to change the wire so I don't have to remember which axis motor is reversed.

-Mike


Dave Schwartz
 

I think an easier way to verify that the axes are moving in the correct direction is to move them individually with the labelled slew buttons in the app. This is because with a GEM the combined movements can be a bit confusing.

Start with the telescope in the home position (dec axis vertical with counterweights down, OTA pointing to NCP). Connect the app, start tracking (tracking menu) and then go to the Guide/Focus menu. Use the option dropdown (three vertical dots in top right) and set the guide rate to Max. Press the 'S' button to get the DEC well away from the pole (~45 degrees) so we don't get confused by the 'pole-crossing' issue. Then use the N/S/E/W buttons to verify that the OTA pointing goes, respectively, back toward the pole/farther from the pole/toward the eastern horizon/toward the western horizon. If it does either of the N/S or E/W motions improperly then that axis needs to be reversed either by swapping around one of the coil wire pair on that motor or by setting the REVERSE parameter and reloading the software.

On 2020-11-30 1:27 p.m., Mike Ahner wrote:
On Mon, Nov 30, 2020 at 12:19 PM, <timtooley35@gmail.com> wrote:

But, despite having what I think is all proper setup completed,
when I tell it to goto an Alignment star the mount does not end up
pointing even in the proper quadrant of the sky. In SkySafari you
can see the scope moving across its star map and settles on the
chosen star, so it thinks it has slewed correctly....but the scope
is not even pointing in the right part of the sky.

One of your stepper motors, RA or DEC or both are running the wrong direction.
First, choose a star that you know where is located in the sky and watch the RA axis-- It should move in the correct direction to point the star. Then watch the DEC axis, same thing. My mount did that, I tried to point to a star in the East and instead it was point West and down toward the ground.

It's an easy fix, either swap wires of 1 of the 2 pairs or just change the direction in the config.h file. You can do that first then swap the wires if you wish or you can just do it in the software and leave it. I like to change the wire so I don't have to remember which axis motor is reversed.

-Mike


Dave Schwartz
 

Also, make sure your UTC offset is set correctly. Many people set it to the same value as their time zone but OnStep needs it to be of the opposite sign (a quirk of the LX200 protocol used under the hood). For EST, that would be +5 (not the -5 of the time zone). The easiest way to get it set properly is to use the app.

On 2020-11-30 3:16 p.m., Dave Schwartz wrote:
I think an easier way to verify that the axes are moving in the correct direction is to move them individually with the labelled slew buttons in the app. This is because with a GEM the combined movements can be a bit confusing.

Start with the telescope in the home position (dec axis vertical with counterweights down, OTA pointing to NCP). Connect the app, start tracking (tracking menu) and then go to the Guide/Focus menu. Use the option dropdown (three vertical dots in top right) and set the guide rate to Max. Press the 'S' button to get the DEC well away from the pole (~45 degrees) so we don't get confused by the 'pole-crossing' issue. Then use the N/S/E/W buttons to verify that the OTA pointing goes, respectively, back toward the pole/farther from the pole/toward the eastern horizon/toward the western horizon. If it does either of the N/S or E/W motions improperly then that axis needs to be reversed either by swapping around one of the coil wire pair on that motor or by setting the REVERSE parameter and reloading the software.

On 2020-11-30 1:27 p.m., Mike Ahner wrote:
On Mon, Nov 30, 2020 at 12:19 PM, <timtooley35@gmail.com> wrote:

    But, despite having what I think is all proper setup completed,
    when I tell it to goto an Alignment star the mount does not end up
    pointing even in the proper quadrant of the sky. In SkySafari you
    can see the scope moving across its star map and settles on the
    chosen star, so it thinks it has slewed correctly....but the scope
    is not even pointing in the right part of the sky.

One of your stepper motors, RA or DEC or both are running the wrong direction.
First, choose a star that you know where is located in the sky and watch the RA axis-- It should move in the correct direction to point the star. Then watch the DEC axis, same thing. My mount did that, I tried to point to a star in the East and instead it was point West and down toward the ground.

It's an easy fix, either swap wires of 1 of the 2 pairs or just change the direction in the config.h file. You can do that first then swap the wires if you wish or you can just do it in the software and leave it. I like to change the wire so I don't have to remember which axis motor is reversed.

-Mike


timtooley35@...
 

Khalid and Mike,
My behavior is very similar to what Mike described...when I chose Altair my scope was pointing almost in the opposite direction where eyepiece end of the scope was pointing at least in the general area of the star but the scope was pointing to the ground.
There could be other config issues like those mentioned but based on this I think I need to start with changing the AXIS1 DRIVER REVERSE and AXIS2 DRIVER REVERSE from the current setting of ON.to OFF.
I'll do the test Mike describes to verify both are going in the wrong direction but based on where the scope ends up I am suspecting both.

Since I received a completed kit from George, I'll have to get the code development environment setup and rebuild with the modified configuration file and flash the update. 
That should go ok as I have SW development experience.

Thanks for "pointing" me in the right direction....I wasa losing my mind!
Tim


JOAN
 

Do you mean that if I use Stellarium or Kstars I must invert the sign?


Dave Schwartz
 

I can only vouch for Stellarium (and any other program connected via ASCOM) but, yes. The sign of the UTC offset is opposite from what you know of as your time zone. This is because they are inverses of each other. The time zone is generally defined as where your local time is with respect to UTC. UTC offset is defined as the amount of time you need to add to your local time to get to UTC.

In my case, I am in the Eastern (north America) time zone, which is -5 but my UTC offset is +5. Here's a screen shot of my OnStep ASCOM properties:

On 2020-12-01 8:19 a.m., JOAN wrote:
Do you mean that if I use Stellarium or Kstars I must invert the sign?


Jay Murphy
 

Mine does this of the date/time/location aren't correct. Refreshing it all in the Android app fixes it for me. Mine also does this when I connect it to NINA and sync NINA to the mount location. It's like it gets confused which side of the pier it's on.