Topics

Onstep on Astroberry


 

Hello....Is there anyone who uses astroberry?
I have a problem here I use raspberry pi 4 and Onstep (STM32) telescope controller. I start the session and OnStep indi not connect, give me a warning "Port / dev / ttyUSB0 is already used by another driver or process" How can I resolve this issue?
 
 
 

 


Khalid Baheyeldin
 

On Fri, Apr 3, 2020 at 06:21 AM, Hanif Nanda wrote:
Hello....Is there anyone who uses astroberry?
I have a problem here I use raspberry pi 4 and Onstep (STM32) telescope controller. I start the session and OnStep indi not connect, give me a warning "Port / dev / ttyUSB0 is already used by another driver or process" How can I resolve this issue?
Yes, there are people who use AstroBerry with OnStep.

And this question has come up before.

See this thread, and that thread.


Gábor Jakus
 

Hello,

I use latest Astroberry on RPi 3B+, with STM32 controller, and I had the same issue. I asked it in the issue session on Astroberry's Github page, and got a partial solution. Here it is: https://github.com/rkaczorek/astroberry-server/issues/62
The /dev/ttyUB0 is used by gpsd (if I am right) and if I disable it, I can connect the telescope in Kstars.
My session is the following:
1. Power on OnStep
2. Power on RPi, start Kstars
4. Run the gpsd disabling command in terminal:
sudo systemctl stop gpsd.service sudo systemctl stop gpsd.socket sudo systemctl disable gpsd.service sudo systemctl disable gpsd.socket
5. Try to connect the scope in Kstars (wich will fail) 
6. Power down OnStep, and power it on
7. Connect the scope again. 

This method is working for me, but this is just a partial solution. I don't know, why must I disable the gpsd at every boot, but that is the case to get it work. Sorry, this is not a professional answer to your question, but hope this helps. 

Best regards! 

Hanif Nanda via groups.io <hanifnanda=rocketmail.com@groups.io> ezt írta (időpont: 2020. ápr. 3., P 12:21):

Hello....Is there anyone who uses astroberry?
I have a problem here I use raspberry pi 4 and Onstep (STM32) telescope controller. I start the session and OnStep indi not connect, give me a warning "Port / dev / ttyUSB0 is already used by another driver or process" How can I resolve this issue?
 
 
 

 


daziemann@...
 

This is Terrific.

I used Gabor's procedure to connect my OnStep SkyView Pro to my Astroberry Pi 4over wifi. Waiting for dark and clear-is skies to do a checkout of system ops, but it mostly works great in my office.

Great Job.