PHD2 guide -microstep rate shifting


Eric Esch
 

I built an MKS based onstep with tmc2130 drivers for both ra and dec axis. Also there is one tmc2130 driving a focuser. All of this is on a custom built drive system for the original fork. Ran through NINA, And linked to the mount through WiFi. 
My question with phd2 is that it guides fine, but after slewing to a couple different targets and reinitializing auto guiding, occasionally when starting guiding it is moving a huge amount. Almost like it cant mange the change of micro stepping. I am not sure how the micro stepping change is handled vs how nina\phd command the mount to track. I am assuming with lx200 commands? What might cause it to act in this manner? PHD freaks out after and forces a calibration that will fail because the mount move a massive amount in relation to how much it should move. After i power the mount off and reboot it, reinitialize, it works fine.  I did notice i can go to the IP address and change the slew rate and it will also affect it by causing the issue or fixing it depending on what i move it to. 


Lloyd Simons
 

This is the same behavior that I observe as well and mentioned here: https://onstep.groups.io/g/main/message/36837

You may be onto something about the microstep switching. I never observed this with my build with the LV8729 drivers, only with the TMC5160 (I slew at 4 microsteps and track at 16). I am able to do what Mark suggested in the above post to get it to work properly. I go to the wifi web page and tap on the guide direction buttons and it will then switch to the proper behavior. This seems like a bug. Any thoughts Howard?


Eric Esch
 

Do you tap the guide direction buttons or the guide speed buttonns? I will try it tonight and see if it fixes my issue? Is there a specific order you tap them in?

On Sat, Sep 18, 2021 at 9:20 AM Lloyd Simons <simonsl23@...> wrote:
This is the same behavior that I observe as well and mentioned here: https://onstep.groups.io/g/main/message/36837

You may be onto something about the microstep switching. I never observed this with my build with the LV8729 drivers, only with the TMC5160 (I slew at 4 microsteps and track at 16). I am able to do what Mark suggested in the above post to get it to work properly. I go to the wifi web page and tap on the guide direction buttons and it will then switch to the proper behavior. This seems like a bug. Any thoughts Howard?


Lloyd Simons
 

Just the direction buttons. I tapped on all 4, in no specific order.


Lloyd Simons
 

Update: I first had to press the proper guide rate (for me 0.5x) then tap the directional buttons. The it switched to the correct rate.


Eric Esch
 

So I played with it a little tonight, and found out a little more info. Can anyone confirm this behavior with their mounts….   The mount switches microstepping count correctly when being command to a slew to, or manual slew. Also when I manually select a guide rate and then use the buttons it will change rates and act accordingly, but if I leave it in the slow rate and go back to Nina, the slew to command takes a second longer then normal to initiate. What I am assuming is the time it takes to check microstepping setting and assign the proper rate for slew. But if I leave the mount as the last movement being a fast slew phd will try to guide at that rate. I confirmed it will calibrate and guide if I first manually set guide speed from the ip first or having the last move initiated be a guide speed move. (Framing centering, etc) 

So, how does onstep decide the proper microstepping to use? Is it by by step amount? Or is it a program requested speed? Maybe a specific type of move gets a specific rate assigned no matter the distance? I am not familiar with what the commands sent from phd2 are but I am assuming onstep can not tell the difference between a slew to and a guide command from phd. 

A little research shows me:

Command:     :Mn#     :Ms#     :Me#     :Mw#
Response:     (none)

Command motion in the direction specified (n=north, s=south, e=east, w=west) the currently selected guide or centering rate. Motion will continue until a quit command is issued.

Ate these the same commands phd2 is using?

 


Eric Esch
 

Also found these:

Command:    :RG#     :RG0#     :RG1#     :RG2#
Response:     none

Selects guide rate for the N-S-E-W buttons. Optionally selects 0.25x (:RG0#), 0.5x (:RG1#), or 1.0x (:RG2#). If no index is provided (:RG#), the previously selected guide rate will be used, else the power up default of 0.5x will be assumed by the motor drive. The indexes are extensions of the Meade protocol.




Khalid Baheyeldin
 

On Sat, Sep 18, 2021 at 10:35 PM, Lloyd Simons wrote:
Update: I first had to press the proper guide rate (for me 0.5x) then tap the directional buttons. The it switched to the correct rate.

OnStep has this peculiar behaviour with 1X: any time you select it, it will 'stick', and therefore overrides what you have selected earlier (e.g 0.5X).

So it looks to me that NINA uses 1X speed at some point, and that resets the pulse guiding speed to 1X, instead of 0.5X.

I do not observe this with INDI (silently overriding the guide speed), and others have not reported it with other sequence managers or planetariums.


Eric Esch
 

will onstep switch between .25 and .5 correctly? Or which should i select before i attempt to start autoguiding


Lloyd Simons
 

OnStep has this peculiar behaviour with 1X: any time you select it, it will 'stick', and therefore overrides what you have selected earlier (e.g 0.5X).
I can say that this also happened when I was using 1.0x as well. What makes me think that this isn't the issue is that I can hear the motors "rev" like it is slewing. I would expect to not hear them at just a 2x difference. 


Khalid Baheyeldin
 

On Sun, Sep 19, 2021 at 04:51 PM, Lloyd Simons wrote:
I can say that this also happened when I was using 1.0x as well. What makes me think that this isn't the issue is that I can hear the motors "rev" like it is slewing. I would expect to not hear them at just a 2x difference. 
If you have backlash values configured, then OnStep will step through that many arc seconds at high speed (which is 25X sidereal speed by default), and that is probably what you hear.


Eric Esch
 

I tried setting the rate to 1 and then hitting each direction on the ip interface. PHD2 had no issue calibrating and then tracking. 
Is there a way to have onstep set tracking rates to 1x automatically after a slew?


Lloyd Simons
 

I am still having issues with tracking rate and guide rate. After a slew in NINA the tracking rate is too fast. I pushed the manual move axis buttons in NINA to get the mount to track at the proper rate. However, when I tried to guide I observed the same behavior as before (rate is way too high). I spent 15 min mashing the guide rate and NSEW buttons on the onstep website before the mount finally started responding at the proper rate. This is quite cumbersome and I believe will cause trouble after auto meridian flip.  Based on my experience and what Eric has seen this seems to be a bug (maybe in NINA). In need to do some testing in another program to confirm.


Eric Esch
 

I agree. My fix has been to turn off automatic starting of autoguiding, and before I tell phd to start tracking I go the the web portal and click .25x rate and push every manual direction, then 1x and then again every direction. Then go back to PHD2 and it works fine. FYI my apt does the same thing as NINA. So I believe it to be on the onstep side. 


David Summa <dave@...>
 

I am keen to hear about this. I too am struggling with OnStep which came OEM with my E.fric mount. 1 month in and zero successful images yet.
I have 2 setups: 1 uses ONStep ASCOM driver and NINA. Connecting works flawlessly. i found using .25x guiding and slow slew works for the purposes of slewing reliably and getting PhD2 to do a calibration. Guiding at .75x and 1X led to a huge jump at the start of every calibration and not one ever completed successfully. However, .25x is not enough for actual guiding as the pulses sent to my mount are never enough to recenter the star. So as you stated, every auto meridian flip failed to recenter and I lost everything after meridian on every session. I go to sleep rather that wait at the scope so I did not do a manual recenter.

I also tried OnStep with my ASIAir Pro. Their firmware now has 2 OnStep telescope settings - OnStep Electronics and OnStep beta. Neither works for me. Scope will start to slew for about 20 degrees then just stop. No commands whatsoever move it in any direction whether using Air app or the OnStep app which I can access directly via WiFi. I have only tried USB connect from mount to PC/Air.

I would appreciate setting advice or firmware changes if anyone has either system working.
Regards,
Dave


Eric Esch
 

I would need more information about your hardware, the rate shifting occurs in tmc2130 type drivers that can change microstepping on the fly. If your system doesn’t do that it would not be the same issue. If it does, I would suggest that after a slew, go through the process I said about setting onstep to .25x in the web interface, then moving the mount each direction with the manual buttons, then setting to 1x and moving each direction with the buttons, then after that. Don’t slew or change rate, give phd2 a try. If you slew or click another rate you will need to reset with the provided procedure. 


David Summa <dave@...>
 

So I am an outlier in the group, in that I did not build my OnStep.  It came new as the OEM stepper driver for the E.fric mount.  So, assuming your email refers to OnStep hardware and not mount, I cannot answer, as I do not know.  If you have identified the problem, how do I get the driver to not jump?


Eric Esch
 

To be honest I have no idea what they use. If anyone else knows and can chime in on the hardware specs I may be able to help.


Khalid Baheyeldin
 

This guide rate issue is a frequently asked question on this list.

This issue is reported in two different forms:

1. If you have the guide rate to 0.5X or 0.25X, then you change the guide speed to 1X, OnStep will forget about the 0.5 and 0.25, and will use 1X from that point on, unless you set it back to 0.5/0.25 manually again. This happens from any OnStep client (Android App, SHC, ASCOM, INDI).

2. A specific NINA issue. I don't use NINA, so can't comment further, but it seems that NINA does something (probably the above: set speed to 1X overriding the 0.5/0.25). So it seems that NINA internally changes the speed to 1X overriding the "lower than 1X" speed implicitly.


David Summa <dave@...>
 

Ok I can run that down on the NINA Discord forum.  They are terrific at getting to the bottom of these issues fast.   Will report back.  FYI: NINA is amazing software that gets better in leaps and bounds.  It now is better than anything else I have ever used, but not simple.  Cuiv YouTube videos are best support out there for NINA.  
Regards,
Dave

On Oct 18, 2021, at 10:23 AM, Khalid Baheyeldin via groups.io <kbahey@...> wrote:

This guide rate issue is a frequently asked question on this list.

This issue is reported in two different forms:

1. If you have the guide rate to 0.5X or 0.25X, then you change the guide speed to 1X, OnStep will forget about the 0.5 and 0.25, and will use 1X from that point on, unless you set it back to 0.5/0.25 manually again. This happens from any OnStep client (Android App, SHC, ASCOM, INDI).

2. A specific NINA issue. I don't use NINA, so can't comment further, but it seems that NINA does something (probably the above: set speed to 1X overriding the 0.5/0.25). So it seems that NINA internally changes the speed to 1X overriding the "lower than 1X" speed implicitly.