Topics

sticky Sky Planetarium

Howard Dutton
 

Version 4.46 of SP is now available.

This was mostly a rework of the sub-window display properties to enable correct scaling of dialogs on Windows 10.  It makes the UI significantly more pleasant to work in on certain modern systems with high resolution displays.  I made numerous little dialog design improvements for consistency, etc. too.

Corrected a bug where a 9-star align in OnStep would trigger error messages (bad range check.)

Plate solving now automatically selects between "None" and "Telescope" coordinates depending on their availability.  Also, a setting of 0 for scaling now omits sending scaling information with the plate solve request.

http://www.stellarjourney.com/index.php?r=site/software_sky

Howard Dutton
 

Sky Planetarium (using OnStep master branch) now has support for the display of Dec limits for tangent arm equipped mounts.  You can also see the display of under-pole (Axis1 min/max) limits here where min and max have different values which wasn't supported prior to the latest SP release (4.47) either.

Howard Dutton
 
Edited

I continue to work on SP, at version 4.51 presently:

  • The magnifier is now more animated and "snaps" to objects as they are found under the cursor.
  • The imaging console spins off threads to handle some image processing tasks.  Much smoother overall, especially with very large and/or color images that take a long time to process.
  • The imaging console has a reworked filter-wheel control logic that again is less disruptive.
  • The POI (Points of Interest) facility now includes the ability to select the Telescope position.  In other words, the magnifier (lower left) can now track the telescope.

simpsonj@...
 

Your link above goes to ver 4.52.  When I try to install it, Norton gives me grief about it and refuses to allow the installation to proceed.  Do I need to uninstall the previous version first?

Howard Dutton
 

On Sat, Jul 25, 2020 at 09:34 AM, <simpsonj@...> wrote:
Your link above goes to ver 4.52.
That's the latest at the moment.

  When I try to install it, Norton gives me grief about it and refuses to allow the installation to proceed.
Virus scanners, pain in the neck...  if you have any doubts you can review this:

https://www.virustotal.com/gui/file/99ea72e2e39a6005ea8da76179b54566be5946e9155f32d15769282e3aed4c6a/detection


Do I need to uninstall the previous version first?
No.