Strange issue with SHC


westopping@...
 

I am using a 1.3 inch OLED but getting the right side cut off. See picture.

It is an ssh1106 and should be 128x64.

Wes


Ken Hunter
 

Check your config.h for the SHC... It should be an SH1106

// DISPLAY -------------------------------------------------------------------------------------------------------------------------
#define DISPLAY_LANGUAGE             L_en //      L_en, English. Specify language with two letter country code, if supported.    Adjust
#define DISPLAY_OLED                  SH1106 //      SH1106, OLED 1.3" I2C display commonly used. SSD1306 is a 0.96" OLED display.    Infreq
                                                                       //       SSD1309 is a 2.3" I2C display (w/Reset on ESP32 Pin23 or Teensy Pin14.)


westopping@...
 

That is what it is set to.


Ken Hunter
 

you said...
It is an ssh1106 and should be 128x64.

If your config is correct, your display is wrong. **it happens.


Dave Schwartz
 

I have had 1.3" displays that had the driver we usually associate with 0.9" displays (I think the one I sent to Howard was one of them). So try the other setting... No harm will result.


On October 17, 2021 3:52:02 p.m. EDT, Ken Hunter <kb7hunter@...> wrote:
you said...
It is an ssh1106 and should be 128x64.

If your config is correct, your display is wrong. **it happens.
--
Sent from my Android device with K-9 Mail. Please excuse my brevity.


Drew 🔭📷🚴‍♂️
 

That looks like the U8G2 library version issue to me. Switch to v2.28.10 and reflash.


westopping@...
 

It looks like the U8G2 version was the issue. I had the newest one before.

Wes