Topics

Wemos D1 mini pro compile problem


Harry Wu
 

Hello everyone,

I'm using MaxPCB v2 with Teensy3.6 and Wemos D1 mini pro,
I've successfully compile Teensy and I can control it with usb connected to my computer,
when I compile the wemos, arduino IDE told me the upload was done,
but I plug wemos back to the board, I search for it's SSID,
it's not "OnStep" but "ESPXXXX",
I've upload the wifi add-on many times to wemos, it still show "ESPXXXX".

Is there anything I can do, or buy a new wemos?
Thank You for your time.


regard
Harry Wu


Dave Schwartz
 

Your WeMos is functioning, its just not connecting to the controller. Someone with a MaxPCB will have to help you with the details. As far as the ESP_xxxxxx SSID, that's just what it does before the controller connection is made. That is the server's default SSID (the xxxxxx is the last six characters of the MAC address) but it is changed to ONSTEP once the controller connection is established.

On 2020-11-22 11:26 a.m., Harry Wu wrote:
Hello everyone,

I'm using MaxPCB v2 with Teensy3.6 and Wemos D1 mini pro,
I've successfully compile Teensy and I can control it with usb connected to my computer,
when I compile the wemos, arduino IDE told me the upload was done,
but I plug wemos back to the board, I search for it's SSID,
it's not "OnStep" but "ESPXXXX",
I've upload the wifi add-on many times to wemos, it still show "ESPXXXX".

Is there anything I can do, or buy a new wemos?
Thank You for your time.


regard
Harry Wu


Harry Wu
 

So there’s a problem with pcb,
maybe the soldering, or the female pin header?
controller is fine, i can connect it with usb.
Is there anyone know where’s the problem?